Bug 150608 - Web Inspector: "No Filter Results" message overlaps Debugger sidebar sections
Summary: Web Inspector: "No Filter Results" message overlaps Debugger sidebar sections
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Matt Baker
URL:
Keywords: InRadar
: 152350 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-27 15:00 PDT by Matt Baker
Modified: 2015-12-31 11:17 PST (History)
8 users (show)

See Also:


Attachments
[Image] Overlapping message (381.51 KB, image/png)
2015-10-27 15:00 PDT, Matt Baker
no flags Details
[Screenshot] Smarter filter message placement (192.90 KB, image/png)
2015-12-18 18:14 PST, Matt Baker
no flags Details
[Patch] Proposed Fix (35.07 KB, patch)
2015-12-18 18:48 PST, Matt Baker
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Baker 2015-10-27 15:00:06 PDT
Created attachment 264164 [details]
[Image] Overlapping message

* SUMMARY
No Filter Results message overlaps Debugger sidebar sections. The message element should remain within Scripts details section.

* STEPS TO REPRODUCE
1. Inspector -> Debugger tab
2. Force the page to pause in the debugger
3. Enter nonsense filter text so all scripts are filtered
  => Message overlaps other sidebar sections other than Scripts (Call Stack, Pause Reason)
Comment 1 Radar WebKit Bug Importer 2015-10-27 15:00:31 PDT
<rdar://problem/23284314>
Comment 2 Matt Baker 2015-10-28 13:07:12 PDT
This will require additional logic to handle the three cases involving a filtered tree outline in the navigation sidebar:

1) The tree is a child of the panel's content element. In this case the message needs to be a child of the content area, i.e. the current way we do things.

2) The tree is a descendent of a details section, and other details sections are visible (e.g. Debugger sidebar when paused). In this case the message needs to be a child of the details section to which the tree belongs.

3) The tree is a descendent of a details section, and other details sections are hidden (e.g. Debugger sidebar when not paused). The message should be handled as in case 1.
Comment 3 Matt Baker 2015-12-16 11:58:14 PST
*** Bug 152350 has been marked as a duplicate of this bug. ***
Comment 4 Joseph Pecoraro 2015-12-17 11:48:33 PST
This prevents clicking in the sidebar and it is not obvious why the clicks are not working. This is important to fix.
Comment 5 Timothy Hatcher 2015-12-17 13:43:57 PST
We also might want to add pointer-events: none to these elements to avoid bugs like this. Even though it would still overlap, clicks would work. That way accidental overlaps are not catastrophic.
Comment 6 Matt Baker 2015-12-18 18:14:29 PST
Created attachment 267668 [details]
[Screenshot] Smarter filter message placement

Filter message containers are now placed at the correct level in the DOM.
Comment 7 Matt Baker 2015-12-18 18:48:38 PST
Created attachment 267675 [details]
[Patch] Proposed Fix
Comment 8 BJ Burg 2015-12-27 19:46:39 PST
Comment on attachment 267675 [details]
[Patch] Proposed Fix

Great work. I couldn't find any regressions in my testing with the patch applied. Let's try it out when you are ready.
Comment 9 WebKit Commit Bot 2015-12-31 11:17:44 PST
Comment on attachment 267675 [details]
[Patch] Proposed Fix

Clearing flags on attachment: 267675

Committed r194460: <http://trac.webkit.org/changeset/194460>
Comment 10 WebKit Commit Bot 2015-12-31 11:17:49 PST
All reviewed patches have been landed.  Closing bug.