Rename the PICTURE_SIZES flag to CURRENTSRC
Created attachment 263369 [details]
Attachment 263369 [details] did not pass style-queue:
ERROR: Source/WebCore/ChangeLog:8: You should remove the 'No new tests' and either add and list tests, or explain why no new tests were possible. [changelog/nonewtests] 
Total errors found: 1 in 22 files
If any of these errors are false positives, please file a bug against check-webkit-style.
Created attachment 263370 [details]
As a split from https://bugs.webkit.org/show_bug.cgi?id=150230 this patch renames the PICTURE_SIZES flag into CURRENTSRC (which is the attribute that this flag is used for now).
Created attachment 263454 [details]
Comment on attachment 263454 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=263454&action=review
> -ENABLE_PICTURE_SIZES = ;
> +ENABLE_CURRENTSRC = ;
These files are slightly sorted. You should probably move CURRENTSRC to earlier in the list.
> - WEBKIT_OPTION_DEFINE(ENABLE_PICTURE_SIZES "Toggle sizes attribute support" PRIVATE OFF)
> + WEBKIT_OPTION_DEFINE(ENABLE_CURRENTSRC "Toggle currentSrc attribute support" PRIVATE OFF)
Created attachment 263557 [details]
Created attachment 263559 [details]
Thanks for reviewing! :) Re-sorted these files and some others.
Comment on attachment 263559 [details]
Clearing flags on attachment: 263559
Committed r191334: <http://trac.webkit.org/changeset/191334>
All reviewed patches have been landed. Closing bug.