Bug 149620 - Fix the ARM build after r190192
Summary: Fix the ARM build after r190192
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Csaba Osztrogonác
URL:
Keywords:
Depends on:
Blocks: 108645 148413
  Show dependency treegraph
 
Reported: 2015-09-29 03:14 PDT by Csaba Osztrogonác
Modified: 2015-10-01 07:52 PDT (History)
4 users (show)

See Also:


Attachments
Patch (1.52 KB, patch)
2015-09-29 03:16 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff
Patch (1.74 KB, patch)
2015-09-29 03:59 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff
Patch (1.89 KB, patch)
2015-09-29 04:04 PDT, Csaba Osztrogonác
darin: review+
Details | Formatted Diff | Diff
patch for landing (1.85 KB, patch)
2015-10-01 03:38 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2015-09-29 03:14:02 PDT
https://trac.webkit.org/changeset/190192 broke the build on ARM Linux:

../../Source/WebCore/platform/graphics/FontFeatureSettings.h: In static member function âstatic void WebCore::FontFeatureTagHashTraits::constructDeletedValue(WebCore::FontFeatureTag&)â:
../../Source/WebCore/platform/graphics/FontFeatureSettings.h:50:134: error: narrowing conversion of -1 from int to char inside { } [-Werror=narrowing]
     static void constructDeletedValue(FontFeatureTag& slot) { new (NotNull, std::addressof(slot)) FontFeatureTag({{ -1, -1, -1, -1 }}); }

The root of the problem is that char is unsigned on ARM.
Comment 1 Csaba Osztrogonác 2015-09-29 03:16:16 PDT
Created attachment 262057 [details]
Patch
Comment 2 Csaba Osztrogonác 2015-09-29 03:59:52 PDT
Created attachment 262060 [details]
Patch
Comment 3 Csaba Osztrogonác 2015-09-29 04:04:44 PDT
Created attachment 262061 [details]
Patch
Comment 4 Darin Adler 2015-09-29 09:34:14 PDT
Comment on attachment 262061 [details]
Patch

A little messy; would be nice to have a named constant for static_cast<char>(0xFF) to avoid repeating it so many times. But seems fine.
Comment 5 Csaba Osztrogonác 2015-10-01 03:38:45 PDT
Created attachment 262245 [details]
patch for landing
Comment 6 WebKit Commit Bot 2015-10-01 05:36:05 PDT
Comment on attachment 262245 [details]
patch for landing

Clearing flags on attachment: 262245

Committed r190402: <http://trac.webkit.org/changeset/190402>