Bug 149594 - [GStreamer] Bump internal jhbuild versions to 1.6.3
Summary: [GStreamer] Bump internal jhbuild versions to 1.6.3
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Gtk (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: ChangSeok Oh
URL:
Keywords:
Depends on: 152043
Blocks: 143211
  Show dependency treegraph
 
Reported: 2015-09-28 03:25 PDT by Philippe Normand
Modified: 2016-02-22 03:27 PST (History)
12 users (show)

See Also:


Attachments
Patch (18.51 KB, patch)
2015-10-20 05:45 PDT, ChangSeok Oh
no flags Details | Formatted Diff | Diff
Patch (20.06 KB, patch)
2015-10-22 01:22 PDT, ChangSeok Oh
no flags Details | Formatted Diff | Diff
patch (26.23 KB, patch)
2016-02-18 03:23 PST, Philippe Normand
mcatanzaro: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Normand 2015-09-28 03:25:06 PDT
At some point, rather sooner than later :), we should check the tests with the gst 1.6.0 release and bump our jhbuild at least.

Later on we could also remove gst < 1.4.x support (if there's still code with a hard-dependency on this).
Comment 1 Xabier Rodríguez Calvar 2015-09-28 04:12:55 PDT
I added dependency with bug 149580 because before testing anything related to multimedia we need the tests to work.
Comment 2 Philippe Normand 2015-09-28 04:15:17 PDT
(In reply to comment #1)
> I added dependency with bug 149580 because before testing anything related
> to multimedia we need the tests to work.

That doesn't have much to do with GStreamer. Those tests are related with the UserMediaRequest, higher WK2 API level.
Comment 3 Xabier Rodríguez Calvar 2015-09-28 04:18:11 PDT
(In reply to comment #2)
> (In reply to comment #1)
> > I added dependency with bug 149580 because before testing anything related
> > to multimedia we need the tests to work.
> 
> That doesn't have much to do with GStreamer. Those tests are related with
> the UserMediaRequest, higher WK2 API level.

Yeah, read too quick, sorry.
Comment 4 ChangSeok Oh 2015-10-20 05:45:14 PDT
Created attachment 263574 [details]
Patch
Comment 5 ChangSeok Oh 2015-10-20 05:46:27 PDT
(In reply to comment #4)
> Created attachment 263574 [details]
> Patch

@Philip Please feel free to give it r+ when you think it's ready.
Comment 6 Philippe Normand 2015-10-20 06:09:57 PDT
Have you checked the media tests?
Comment 7 ChangSeok Oh 2015-10-21 04:05:18 PDT
(In reply to comment #6)
> Have you checked the media tests?

Yes I have. I could not see any regression for the media tests when I tried.
BTW do we need to update https://trac.webkit.org/browser/trunk/Source/cmake/FindGStreamer.cmake#L88 as well?
Comment 8 Philippe Normand 2015-10-21 04:08:20 PDT
(In reply to comment #7)
> (In reply to comment #6)
> > Have you checked the media tests?
> 
> Yes I have. I could not see any regression for the media tests when I tried.
> BTW do we need to update
> https://trac.webkit.org/browser/trunk/Source/cmake/FindGStreamer.cmake#L88
> as well?

Yes, 1.5.x was a development version.
Comment 9 Philippe Normand 2015-10-21 04:20:49 PDT
Also the EWS build failed. Not sure what's going on there.
Comment 10 ChangSeok Oh 2015-10-22 01:22:28 PDT
Created attachment 263807 [details]
Patch
Comment 11 ChangSeok Oh 2015-10-22 01:23:30 PDT
(In reply to comment #9)
> Also the EWS build failed. Not sure what's going on there.

Maybe it needs a clean build?
Comment 12 Philippe Normand 2015-10-22 01:27:54 PDT
(In reply to comment #11)
> (In reply to comment #9)
> > Also the EWS build failed. Not sure what's going on there.
> 
> Maybe it needs a clean build?

I believe patches touching jhbuild modulesets trigger a full rebuild of the dependencies already on the EWS.
Comment 13 Philippe Normand 2015-10-22 01:29:40 PDT
Ah well ignore me :) It's a clean WebKit build that would be needed here.
Comment 14 Philippe Normand 2015-10-22 07:31:00 PDT
Comment on attachment 263807 [details]
Patch

r=me but please coordinate with the gtk buildbot admins to trigger a clean build when landing this.
Comment 15 ChangSeok Oh 2015-10-23 00:43:15 PDT
(In reply to comment #14)
> Comment on attachment 263807 [details]
> Patch
> 
> r=me but please coordinate with the gtk buildbot admins to trigger a clean
> build when landing this.

Hey. philn thanks for the r+. Would you let me know who are the gtk buildbot admins? Maybe kov and KaL?
Comment 16 Philippe Normand 2015-10-23 00:56:09 PDT
Gustavo & Carlos Lopez, now in CC :)
Comment 17 Carlos Alberto Lopez Perez 2015-10-23 03:18:51 PDT
Regarding the buildbots: Any committer can trigger a clean build, you can login with your trac/wiki webkit credentials in the login form that is available in any bot status page.

For the EWS, just ping me on the IRC (nick: clopez) after landing it and I will trigger a clean build.
Comment 18 ChangSeok Oh 2015-10-26 01:11:06 PDT
(In reply to comment #17)
> Regarding the buildbots: Any committer can trigger a clean build, you can
> login with your trac/wiki webkit credentials in the login form that is
> available in any bot status page.
> 
> For the EWS, just ping me on the IRC (nick: clopez) after landing it and I
> will trigger a clean build.

Good to know. Thanks. Here we go. =)
Comment 19 WebKit Commit Bot 2015-10-26 01:58:25 PDT
Comment on attachment 263807 [details]
Patch

Clearing flags on attachment: 263807

Committed r191576: <http://trac.webkit.org/changeset/191576>
Comment 20 WebKit Commit Bot 2015-10-26 01:58:30 PDT
All reviewed patches have been landed.  Closing bug.
Comment 21 Philippe Normand 2015-10-26 05:04:59 PDT
Reverted r191576 for reason:

broke

Committed r191583: <http://trac.webkit.org/changeset/191583>
Comment 22 Philippe Normand 2015-10-26 05:06:24 PDT
(In reply to comment #21)
> Reverted r191576 for reason:
> 
> broke
> 
> Committed r191583: <http://trac.webkit.org/changeset/191583>

Next time I'll remember to quote the revert message when invoking webkit-patch :P
Comment 23 Philippe Normand 2016-02-18 03:23:45 PST
Created attachment 271648 [details]
patch
Comment 24 Michael Catanzaro 2016-02-18 06:12:41 PST
Comment on attachment 271648 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=271648&action=review

> LayoutTests/platform/gtk/TestExpectations:647
> +webkit.org/b/154390 http/tests/media/reload-after-dialog.html [ Skip ]

Instead of marking these as Skip, I would mark them as failing instead, that way we'll notice when they start passing.
Comment 25 Philippe Normand 2016-02-19 00:10:30 PST
Committed r196804: <http://trac.webkit.org/changeset/196804>
Comment 26 Csaba Osztrogonác 2016-02-19 03:59:22 PST
(In reply to comment #25)
> Committed r196804: <http://trac.webkit.org/changeset/196804>

It broke the build on the 32 bit GTK bot:

../DependenciesGTK/Root/include/gstreamer-1.0/gst/gstelement.h:55:27: fatal error: gst/gstconfig.h: No such file or directory
 #include <gst/gstconfig.h>
                           ^
Comment 27 Philippe Normand 2016-02-19 04:03:56 PST
(In reply to comment #26)
> (In reply to comment #25)
> > Committed r196804: <http://trac.webkit.org/changeset/196804>
> 
> It broke the build on the 32 bit GTK bot:
> 
> ../DependenciesGTK/Root/include/gstreamer-1.0/gst/gstelement.h:55:27: fatal
> error: gst/gstconfig.h: No such file or directory
>  #include <gst/gstconfig.h>
>                            ^

A clean build is needed. I did it on the other bots but forgot this one. Thanks for letting me know.
Comment 28 Carlos Alberto Lopez Perez 2016-02-22 03:27:45 PST
(In reply to comment #27)
> (In reply to comment #26)
> > (In reply to comment #25)
> > > Committed r196804: <http://trac.webkit.org/changeset/196804>
> > 
> > It broke the build on the 32 bit GTK bot:
> > 
> > ../DependenciesGTK/Root/include/gstreamer-1.0/gst/gstelement.h:55:27: fatal
> > error: gst/gstconfig.h: No such file or directory
> >  #include <gst/gstconfig.h>
> >                            ^
> 
> A clean build is needed. I did it on the other bots but forgot this one.
> Thanks for letting me know.

Seems you forgot also the GTK+ ARM one? It has been failing to build since then. I have just triggered a clean build now.