Bug 14662 - REGRESSION: Freeze when downloading from macupdate.com
Summary: REGRESSION: Freeze when downloading from macupdate.com
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://macupdate.com/info.php/id/2421...
Keywords: InRadar, Regression
: 14668 14687 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-07-18 11:39 PDT by Alexey Proskuryakov
Modified: 2007-10-04 22:05 PDT (History)
5 users (show)

See Also:


Attachments
sample (9.05 KB, text/plain)
2007-07-18 11:41 PDT, Alexey Proskuryakov
no flags Details
another sample (14.96 KB, text/plain)
2007-07-18 23:28 PDT, David Kilzer (:ddkilzer)
no flags Details
Screenshot of hang (223.80 KB, image/png)
2007-07-18 23:28 PDT, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2007-07-18 11:39:56 PDT
Steps to reproduce:
1) Open http://macupdate.com/info.php/id/24219/ez-money
2) Click "Download Now".

Results: Safari freezes (sample attached). I have reproduced several times in a row.

This is a fairly recent regression (I think, r24064-r24399).
Comment 1 Alexey Proskuryakov 2007-07-18 11:41:13 PDT
Created attachment 15564 [details]
sample

Forgot to mention: this happens with most/all downloads from MacUpdate, I just picked a relatively small file for the report.
Comment 2 Matt Lilek 2007-07-18 12:21:28 PDT
Looking at the sample, but without a Safari machine to test on, I wonder if it was <http://trac.webkit.org/projects/webkit/changeset/24365>
<http://trac.webkit.org/projects/webkit/changeset/24366>
Comment 3 David Kilzer (:ddkilzer) 2007-07-18 23:27:21 PDT
I can confirm this behavior with a local debug build of WebKit r24439 with Safari 3.0 (522.12) on Mac OS X 10.4.10 (8R218).  It took me SIX tries to get it to reproduce, though.

Comment 4 David Kilzer (:ddkilzer) 2007-07-18 23:28:08 PDT
Created attachment 15576 [details]
another sample

Sample of my hang.
Comment 5 David Kilzer (:ddkilzer) 2007-07-18 23:28:48 PDT
Created attachment 15577 [details]
Screenshot of hang
Comment 6 David Kilzer (:ddkilzer) 2007-07-18 23:29:38 PDT
<rdar://problem/5346364>
Comment 7 Matt Lilek 2007-07-19 06:18:44 PDT
*** Bug 14668 has been marked as a duplicate of this bug. ***
Comment 8 David Kilzer (:ddkilzer) 2007-07-20 08:54:24 PDT
*** Bug 14687 has been marked as a duplicate of this bug. ***
Comment 9 David Kilzer (:ddkilzer) 2007-07-20 16:01:04 PDT
Alexey, was this reproduced on a PowerPC or Intel system?

Comment 10 Alexey Proskuryakov 2007-07-20 23:57:28 PDT
I was only testing on a G4.
Comment 11 David Kilzer (:ddkilzer) 2007-10-04 22:05:38 PDT
This must be fixed in the Safari browser, so closing as RESOLVED/INVALID.