Bug 14625 - webarchive does not load related resources when not connected to Internet
Summary: webarchive does not load related resources when not connected to Internet
Status: RESOLVED DUPLICATE of bug 12605
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-15 02:33 PDT by Gennady
Modified: 2007-07-15 15:13 PDT (History)
1 user (show)

See Also:


Attachments
Example webarchive that does not work (13.76 KB, application/zip)
2007-07-15 12:09 PDT, Gennady
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gennady 2007-07-15 02:33:35 PDT
When saved as webarchve web page with images and linked css shows up as saved as plain html page if computer is not connected to the Internet. Images are not displayed and all styles are lost.
Whereas opening that webarchive in TextEdit shows all images fine - this means that they are there embeded in webarchive.
This kind of behavior does not make sense as I save webarchves for later review when I will not be able to view them in Internet (because not conected).

To reproduce:
1. Save any page containing images and linked css as webarchive.
2. Open this webarchive on any other computer which does not have working Internet connection nor cashes for that page.

Expected behaviour : Page shoul show up just the same as it did on the Internet.
In fact: page shows up without images nor styles.

Applies on all versions of Safary and WebKit I ever tested.
Comment 1 David Kilzer (:ddkilzer) 2007-07-15 06:30:04 PDT
Do you have a specific page (URL) that doesn't work?  You're probably hitting one of these bugs, but I'd like to make sure it's not something else:

Bug 11839 Webarchive fails to save CSS files in @import statements
Bug 11850 Webarchive fails to save images referenced in CSS
Bug 12025 WebArchive fails to save background images in <tr> tags

Comment 2 Gennady 2007-07-15 12:04:42 PDT
I believe it shourd work on any page.
There are only two requirements to reproduce: 
- computer is not connected to Internet at the moment
- you did not recently visit these pages on that computer

For a confirmed example I have several webarchives from MySQL references manual. (I'll attach one)
when I try loading any of them only the main HTML renders. All related resources show up in Activity window as unvailable.
What is interesting: webinspector shows all these resources as loaded, but in "Other" section - colored grey.

Cases you mentioned hit on some specific issues (some items do not save) whereas I observe a general  fault that NOTHING loads (when internet is disconnected). However maybe some of mentioned bugs may be treated as a part of this one.
Comment 3 Gennady 2007-07-15 12:09:34 PDT
Created attachment 15524 [details]
Example webarchive that does not work
Comment 4 David Kilzer (:ddkilzer) 2007-07-15 15:02:43 PDT
Confirmed with a local debug build of WebKit r24295 with Safari 3.0 (522.12) on Mac OS X 10.4.10 (8R218).

Comment 5 David Kilzer (:ddkilzer) 2007-07-15 15:10:14 PDT
This is actually a duplicate of Bug 12605.  The very first time the webarchive is opened, the offline resources will load properly (sometimes) with no network.  Any subsequent reloads (with no network) will fail.

* STEPS TO REPRODUCE
1. Disconnect all network connections.
2. Launch Safari/WebKit.
3. Empty the cache using Cmd-Opt-E and click "OK".
4. Open the webarchive.
5. If the page looks like it loaded properly, hit reload.
6. Open the Activity window to view the resources loaded.

* EXPECTED RESULTS
The following resources should be loaded offline:

http://dev.mysql.com/common/css/print.css
http://dev.mysql.com/common/css/screen.css
http://dev.mysql.com/common/img/nswpat80x15.gif
http://dev.mysql.com/common/logos/mysql_100x52-64.gif

* ACTUAL RESULTS
The above resources are not loaded--only the main HTML page is loaded.



*** This bug has been marked as a duplicate of 12605 ***
Comment 6 David Kilzer (:ddkilzer) 2007-07-15 15:13:45 PDT
(In reply to comment #3)
> Created an attachment (id=15524) [edit]
> Example weberchive that does not work

Note that this webarchive suffers from missing resources due to both Bug 11839 and Bug 11850, but the resources that are there should load offline.