Bug 145516 - build-jsc’s —cloop option is broken
Summary: build-jsc’s —cloop option is broken
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Lam
URL:
Keywords:
Depends on: 145515 145543
Blocks: 145636
  Show dependency treegraph
 
Reported: 2015-06-01 09:59 PDT by Mark Lam
Modified: 2015-06-03 23:56 PDT (History)
3 users (show)

See Also:


Attachments
the patch. (1.89 KB, patch)
2015-06-01 10:09 PDT, Mark Lam
no flags Details | Formatted Diff | Diff
patch 2: fixed non-ascii chars. (1.89 KB, patch)
2015-06-01 10:12 PDT, Mark Lam
no flags Details | Formatted Diff | Diff
patch for re-landing. (1.86 KB, patch)
2015-06-02 10:44 PDT, Mark Lam
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Lam 2015-06-01 09:59:41 PDT
After r183516, build-jsc --cloop no longer builds the CLOOP interpreter.  This is because it did not explicitly disable the JIT when --cloop is specified.
Comment 1 Mark Lam 2015-06-01 10:03:03 PDT
We cannot land this fix until https://bugs.webkit.org/show_bug.cgi?id=145515 is resolved.  Otherwise, we’ll have a red CLoop bot.  In reality, we do have a red CLoop bot.  We just have not been building the CLoop and seeing it.
Comment 2 Mark Lam 2015-06-01 10:09:43 PDT
Created attachment 254005 [details]
the patch.
Comment 3 Mark Lam 2015-06-01 10:12:11 PDT
Created attachment 254006 [details]
patch 2: fixed non-ascii chars.
Comment 4 WebKit Commit Bot 2015-06-01 11:18:04 PDT
Comment on attachment 254006 [details]
patch 2: fixed non-ascii chars.

Clearing flags on attachment: 254006

Committed r185066: <http://trac.webkit.org/changeset/185066>
Comment 5 WebKit Commit Bot 2015-06-01 11:18:06 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Filip Pizlo 2015-06-01 20:17:18 PDT
This broke the FTL JIT build.  It's no longer possible to build with LLVM checked out into a local directory after this change.

I will roll this out unless you have a quick fix, since this prevents me from doing any work.
Comment 7 WebKit Commit Bot 2015-06-01 20:25:53 PDT
Re-opened since this is blocked by bug 145543
Comment 8 Mark Lam 2015-06-02 10:34:20 PDT
(In reply to comment #6)
> This broke the FTL JIT build.  It's no longer possible to build with LLVM
> checked out into a local directory after this change.
> 
> I will roll this out unless you have a quick fix, since this prevents me
> from doing any work.

As far as I can tell, this might be the issue:
1. Configurations/LLVMForJSC.xcconfig defines OTHER_LDFLAGS_LLVM = $(OTHER_LDFLAGS_LLVM_$(ENABLE_FTL_JIT)_$(CURRENT_ARCH));
2. This in turn is used to map to OTHER_LDFLAGS_LLVM_ENABLE_FTL_JIT_x86_64 which provides the list of libs to link against.

With the patch, the $ftlJIT case specifies ENABLE_FTL_JIT=ENABLE_FTL_JIT=1 to get the compiler option -DENABLE_FTL_JIT=1.  I suspect that this throws a monkey wrench into configuration setup above.

Once I change it to ENABLE_FTL_JIT=ENABLE_FTL_JIT, the issue is resolved.  I’ll move forward with this as the fix since -DENABLE_FTL_JIT implicitly defines the symbol to 1 anyway i.e. it’s the same as -DENABLE_FTL_JIT=1.
Comment 9 Mark Lam 2015-06-02 10:44:27 PDT
Created attachment 254072 [details]
patch for re-landing.
Comment 10 Mark Lam 2015-06-02 10:49:49 PDT
Patch re-landed in r185110: <http://trac.webkit.org/r185110>.