Bug 145438 - Make the type profiler work with lexical scoping and add tests
Summary: Make the type profiler work with lexical scoping and add tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Saam Barati
URL:
Keywords:
: 145958 (view as bug list)
Depends on: 142944
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-28 09:11 PDT by Saam Barati
Modified: 2015-07-28 15:41 PDT (History)
13 users (show)

See Also:


Attachments
patch (61.50 KB, patch)
2015-07-22 15:00 PDT, Saam Barati
buildbot: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews103 for mac-mavericks (621.08 KB, application/zip)
2015-07-22 15:25 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews105 for mac-mavericks-wk2 (605.80 KB, application/zip)
2015-07-22 15:44 PDT, Build Bot
no flags Details
patch (61.25 KB, patch)
2015-07-28 10:37 PDT, Saam Barati
buildbot: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews102 for mac-mavericks (676.07 KB, application/zip)
2015-07-28 11:20 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews104 for mac-mavericks-wk2 (634.12 KB, application/zip)
2015-07-28 11:34 PDT, Build Bot
no flags Details
patch (61.19 KB, patch)
2015-07-28 12:12 PDT, Saam Barati
ggaren: review+
sbarati: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Saam Barati 2015-05-28 09:11:50 PDT
Some small changes need to be made to how variables are linked up to their global IDs inside CodeBlock.
We will need to refer to CodeBlock's symbol table stack to find lookup variables when they're locally scoped.
Comment 1 Saam Barati 2015-07-10 13:58:43 PDT
*** Bug 145958 has been marked as a duplicate of this bug. ***
Comment 2 Saam Barati 2015-07-22 15:00:55 PDT
Created attachment 257298 [details]
patch
Comment 3 WebKit Commit Bot 2015-07-22 15:02:57 PDT
Attachment 257298 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/bytecompiler/NodesCodegen.cpp:3276:  Missing space after ,  [whitespace/comma] [3]
Total errors found: 1 in 13 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Build Bot 2015-07-22 15:25:23 PDT
Comment on attachment 257298 [details]
patch

Attachment 257298 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/4857734449070080

New failing tests:
js/arguments-iterator.html
js/basic-strict-mode.html
Comment 5 Build Bot 2015-07-22 15:25:26 PDT
Created attachment 257301 [details]
Archive of layout-test-results from ews103 for mac-mavericks

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews103  Port: mac-mavericks  Platform: Mac OS X 10.9.5
Comment 6 Build Bot 2015-07-22 15:44:50 PDT
Comment on attachment 257298 [details]
patch

Attachment 257298 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/4972823466475520

New failing tests:
js/arguments-iterator.html
js/basic-strict-mode.html
Comment 7 Build Bot 2015-07-22 15:44:52 PDT
Created attachment 257302 [details]
Archive of layout-test-results from ews105 for mac-mavericks-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews105  Port: mac-mavericks-wk2  Platform: Mac OS X 10.9.5
Comment 8 Saam Barati 2015-07-28 10:37:04 PDT
Created attachment 257656 [details]
patch
Comment 9 Build Bot 2015-07-28 11:19:58 PDT
Comment on attachment 257656 [details]
patch

Attachment 257656 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/4768745276833792

New failing tests:
js/arguments-iterator.html
js/basic-strict-mode.html
Comment 10 Build Bot 2015-07-28 11:20:03 PDT
Created attachment 257663 [details]
Archive of layout-test-results from ews102 for mac-mavericks

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews102  Port: mac-mavericks  Platform: Mac OS X 10.9.5
Comment 11 Build Bot 2015-07-28 11:34:05 PDT
Comment on attachment 257656 [details]
patch

Attachment 257656 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/5050220253544448

New failing tests:
js/arguments-iterator.html
js/basic-strict-mode.html
Comment 12 Build Bot 2015-07-28 11:34:08 PDT
Created attachment 257665 [details]
Archive of layout-test-results from ews104 for mac-mavericks-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews104  Port: mac-mavericks-wk2  Platform: Mac OS X 10.9.5
Comment 13 Saam Barati 2015-07-28 12:12:59 PDT
Created attachment 257668 [details]
patch

Lets not remove a needed early return :)
Comment 14 Geoffrey Garen 2015-07-28 13:04:19 PDT
Comment on attachment 257668 [details]
patch

r=me
Comment 15 Saam Barati 2015-07-28 13:06:40 PDT
Fixing 32-bit build locally then will commit.
Comment 16 Saam Barati 2015-07-28 15:41:07 PDT
landed in:
http://trac.webkit.org/changeset/187524