MediaDevices [1] is a "name space" object that collects some functionality related to local media devices. It's, for example, home to the Promise-based version of getUserMedia() (unprefixed) and enumerateDevices(). [1] https://w3c.github.io/mediacapture-main/#mediadevices
Created attachment 249834 [details] Proposed patch
Comment on attachment 249834 [details] Proposed patch View in context: https://bugs.webkit.org/attachment.cgi?id=249834&action=review > LayoutTests/fast/mediastream/MediaDevices-getUserMedia.html:20 > +<body> > +<p id="description"></p> > +<div id="console"></div> > +<script> > +description("Tests getUserMedia (Promise-based version on navigator.mediaDevices)"); > + > +function setUserMediaPermission(isGranted) { > + if (window.testRunner) > + testRunner.setUserMediaPermission(isGranted); > + else > + debug("This test can not be run without the testRunner"); > +} > + > +var stream; > +var errorArg; Nit: I think this would be slightly easier to read and understand if it was indented. > Source/WebCore/Modules/mediastream/UserMediaRequest.cpp:204 > RefPtr<NavigatorUserMediaError> error = NavigatorUserMediaError::create(NavigatorUserMediaError::permissionDeniedErrorName(), emptyString()); Shouldn't this be a MediaStreamError? If so, please add a FIXME: with a bug.
(In reply to comment #2) > Nit: I think this would be slightly easier to read and understand if it was > indented. I found a few different styles among the tests, but most tests within the mediastream module seems to be indented so I'll align this test. > > Source/WebCore/Modules/mediastream/UserMediaRequest.cpp:204 > > RefPtr<NavigatorUserMediaError> error = NavigatorUserMediaError::create(NavigatorUserMediaError::permissionDeniedErrorName(), emptyString()); > > Shouldn't this be a MediaStreamError? If so, please add a FIXME: with a bug. I'll do that. Thanks for reviewing.
Created attachment 249978 [details] Patch for landing
Comment on attachment 249978 [details] Patch for landing Bots all green, setting cq+
Comment on attachment 249978 [details] Patch for landing Rejecting attachment 249978 [details] from commit-queue. Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.appspot.com', '--bot-id=webkit-cq-02', 'validate-changelog', '--check-oops', '--non-interactive', 249978, '--port=mac']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit ChangeLog entry in LayoutTests/ChangeLog contains OOPS!. Full output: http://webkit-queues.appspot.com/results/5272158381015040
Created attachment 249983 [details] Patch for landing With reviewer name this time.
Comment on attachment 249983 [details] Patch for landing Clearing flags on attachment: 249983 Committed r182275: <http://trac.webkit.org/changeset/182275>
All reviewed patches have been landed. Closing bug.