Bug 143086 - REGRESSION(181977): It broke the build on the WinCairo bot
Summary: REGRESSION(181977): It broke the build on the WinCairo bot
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alex Christensen
URL:
Keywords:
Depends on:
Blocks: 143040
  Show dependency treegraph
 
Reported: 2015-03-26 01:07 PDT by Csaba Osztrogonác
Modified: 2015-03-27 12:27 PDT (History)
7 users (show)

See Also:


Attachments
Patch (2.10 KB, patch)
2015-03-26 21:24 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2015-03-26 01:07:34 PDT
Can't locate Archive/Zip.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.14/i686-cygwin-threads-64int /usr/lib/perl5/site_perl/5.14 /usr/lib/perl5/vendor_perl/5.14/i686-cygwin-threads-64int /usr/lib/perl5/vendor_perl/5.14 /usr/lib/perl5/5.14/i686-cygwin-threads-64int /usr/lib/perl5/5.14 /usr/lib/perl5/site_perl/5.10 /usr/lib/perl5/vendor_perl/5.10 /usr/lib/perl5/site_perl/5.8 .) at /home/webkitbot/win-cairo-release/build/Tools/Scripts/update-webkit-dependency line 35.
BEGIN failed--compilation aborted at /home/webkitbot/win-cairo-release/build/Tools/Scripts/update-webkit-dependency line 35.
Died at Tools/Scripts/update-webkit-wincairo-libs line 41.
Died at ./Tools/Scripts/build-webkit line 210.
Comment 1 Csaba Osztrogonác 2015-03-26 01:10:33 PDT
It seems https://trac.webkit.org/changeset/181977 is the culprit.
Comment 2 Brent Fulgham 2015-03-26 08:52:51 PDT
Alex, can the WinCairo bot be updated to include the Zip Perl package?
Comment 3 Alex Christensen 2015-03-26 10:50:35 PDT
I installed the zip perl package with this command:
setup-x86.exe -q -P perl-Archive-Zip

Now it fails with a different error:
Can't load '/usr/lib/perl5/5.14/i686-cygwin-threads-64int/auto/IO/IO.dll' for module IO: No such process at /usr/lib/perl5/5.14/XSLoader.pm line 71.
 at /usr/lib/perl5/5.14/i686-cygwin-threads-64int/IO.pm line 11


/usr/lib/perl5/5.14/i686-cygwin-threads-64int/auto/IO/IO.dll exists in cygwin.  What is going on?
Comment 4 Alex Christensen 2015-03-26 21:20:51 PDT
Installing perl-Archive-Zip on Cygwin killed my perl installation somehow.  I installed ActivePerl, and I think with this an Myles' work we could get that working.
Comment 5 Alex Christensen 2015-03-26 21:24:21 PDT
Created attachment 249549 [details]
Patch
Comment 6 Alex Christensen 2015-03-26 21:25:54 PDT
This gets it to build WTF.  I see these errors after this patch.

 Creating library C:\cygwin\home\webkitbot\win-cairo-release\build\WebKitBuild\             Release_WinCairo\lib32\WTF.lib and object C:\cygwin\home\webkitbot\win-cairo-releas             e\build\WebKitBuild\Release_WinCairo\lib32\WTF.exp
  WTF.vcxproj -> C:\cygwin\home\webkitbot\win-cairo-release\build\WebKitBuild\Relea             se_WinCairo\bin32\WTF.dll
  No C:\cygwin\home\webkitbot\win-cairo-release\build\WebKitLibraries\win\tools\Ver             sionStamper\VersionStamper.exe executable. Exiting.
  /usr/bin/bash
  The system cannot find the path specified.
  Failed to build C:\cygwin\home\webkitbot\win-cairo-release\build\Source\JavaScrip             tCore\DerivedSources.make: No such file or directory at build-generated-files.pl li             ne 78.
NMAKE : fatal error U1077: 'perl' : return code '0x2' [C:\cygwin\home\webkitbot\win             -cairo-release\build\Source\JavaScriptCore\JavaScriptCore.vcxproj\JavaScriptCoreGen             erated.vcxproj]
  Stop.
Comment 7 Myles C. Maxfield 2015-03-27 08:56:33 PDT
(In reply to comment #6)
> This gets it to build WTF.  I see these errors after this patch.
> 
>  Creating library
> C:\cygwin\home\webkitbot\win-cairo-release\build\WebKitBuild\            
> Release_WinCairo\lib32\WTF.lib and object
> C:\cygwin\home\webkitbot\win-cairo-releas            
> e\build\WebKitBuild\Release_WinCairo\lib32\WTF.exp
>   WTF.vcxproj ->
> C:\cygwin\home\webkitbot\win-cairo-release\build\WebKitBuild\Relea          
> se_WinCairo\bin32\WTF.dll
>   No
> C:\cygwin\home\webkitbot\win-cairo-
> release\build\WebKitLibraries\win\tools\Ver            
> sionStamper\VersionStamper.exe executable. Exiting.
>   /usr/bin/bash
>   The system cannot find the path specified.
>   Failed to build
> C:\cygwin\home\webkitbot\win-cairo-release\build\Source\JavaScrip           
> tCore\DerivedSources.make: No such file or directory at
> build-generated-files.pl li             ne 78.
> NMAKE : fatal error U1077: 'perl' : return code '0x2'
> [C:\cygwin\home\webkitbot\win            
> -cairo-release\build\Source\JavaScriptCore\JavaScriptCore.
> vcxproj\JavaScriptCoreGen             erated.vcxproj]
>   Stop.

I get the VersionStamper error too, but it seems to be benign. Note that the next error you see is from JavaScriptCore, not WTF.
Comment 8 Myles C. Maxfield 2015-03-27 08:58:11 PDT
Looks fine to me but I'll wait for Brent to give the final go-ahead.
Comment 9 Brent Fulgham 2015-03-27 09:12:28 PDT
Comment on attachment 249549 [details]
Patch

Looks good. I was just waiting for EWS to finish running on it.
Comment 10 WebKit Commit Bot 2015-03-27 10:00:08 PDT
Comment on attachment 249549 [details]
Patch

Clearing flags on attachment: 249549

Committed r182065: <http://trac.webkit.org/changeset/182065>
Comment 11 WebKit Commit Bot 2015-03-27 10:00:13 PDT
All reviewed patches have been landed.  Closing bug.
Comment 12 Csaba Osztrogonác 2015-03-27 10:06:10 PDT
(In reply to comment #10)
> Comment on attachment 249549 [details]
> Patch
> 
> Clearing flags on attachment: 249549
> 
> Committed r182065: <http://trac.webkit.org/changeset/182065>

The build is still broken:

mkdir File::.: Invalid argument; The filename, directory name, or volume label syntax is incorrect at C:/cygwin/home/webkitbot/win-cairo-release/build/Tools/Scripts/webkitdirs.pm line 1678.
Comment 13 Alex Christensen 2015-03-27 10:13:50 PDT
There are also some problems with cygwin's make using /usr/bin/perl because of headers in files like create_hash_table.  I'm taking the bot offline and I plan to fix it next week after Myles finishes patches like https://bugs.webkit.org/show_bug.cgi?id=143084
Comment 14 Myles C. Maxfield 2015-03-27 12:27:00 PDT
(In reply to comment #12)
> (In reply to comment #10)
> > Comment on attachment 249549 [details]
> > Patch
> > 
> > Clearing flags on attachment: 249549
> > 
> > Committed r182065: <http://trac.webkit.org/changeset/182065>
> 
> The build is still broken:
> 
> mkdir File::.: Invalid argument; The filename, directory name, or volume
> label syntax is incorrect at
> C:/cygwin/home/webkitbot/win-cairo-release/build/Tools/Scripts/webkitdirs.pm
> line 1678.

I believe https://bugs.webkit.org/show_bug.cgi?id=143084 fixes this.