Bug 142473 - [CMake] Enable WorkQueue tests for CMake ports
Summary: [CMake] Enable WorkQueue tests for CMake ports
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Martin Robinson
URL:
Keywords:
Depends on: 142447 142493
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-08 21:49 PDT by Martin Robinson
Modified: 2015-03-09 12:02 PDT (History)
2 users (show)

See Also:


Attachments
Patch (1.21 KB, patch)
2015-03-08 21:53 PDT, Martin Robinson
no flags Details | Formatted Diff | Diff
Patch (1.92 KB, patch)
2015-03-09 11:02 PDT, Martin Robinson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Robinson 2015-03-08 21:49:19 PDT
WorkQueue tests exist, but we simply are not compiling them yet.
Comment 1 Martin Robinson 2015-03-08 21:53:40 PDT
Created attachment 248229 [details]
Patch
Comment 2 Darin Adler 2015-03-09 00:10:31 PDT
Comment on attachment 248229 [details]
Patch

Looks like this doesn’t compile on EFL. We should fix that before making this change.
Comment 3 Martin Robinson 2015-03-09 07:34:38 PDT
It seems that the issue is that WorkQueue moved to WTF, but a WorkQeueue dependency for EFL, DispatchQueue, is still part of WebKit2.
Comment 4 Csaba Osztrogonác 2015-03-09 09:34:54 PDT
${WTF_DIR}/wtf/efl should be added to the list of the include directories
in Tools/TestWebKitAPI/PlatformEfl.cmake to fix the EFL build. (after bug142493)
Comment 5 Martin Robinson 2015-03-09 11:02:38 PDT
Created attachment 248259 [details]
Patch
Comment 6 WebKit Commit Bot 2015-03-09 12:02:51 PDT
Comment on attachment 248259 [details]
Patch

Clearing flags on attachment: 248259

Committed r181275: <http://trac.webkit.org/changeset/181275>
Comment 7 WebKit Commit Bot 2015-03-09 12:02:56 PDT
All reviewed patches have been landed.  Closing bug.