Bug 142309 - AX: Crash viewing http://www.last.fm/
Summary: AX: Crash viewing http://www.last.fm/
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Joanmarie Diggs (irc: joanie)
URL:
Keywords: InRadar
: 139284 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-04 14:56 PST by Michael Catanzaro
Modified: 2015-03-23 07:24 PDT (History)
12 users (show)

See Also:


Attachments
backtrace (82.92 KB, text/plain)
2015-03-04 14:56 PST, Michael Catanzaro
no flags Details
Patch (6.70 KB, patch)
2015-03-16 11:45 PDT, Joanmarie Diggs (irc: joanie)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Catanzaro 2015-03-04 14:56:17 PST
Created attachment 247897 [details]
backtrace

When I view http://www.last.fm/ in Epiphany 3.14.2, WebKitGTK+ 2.6.5 the web process sometimes crashes immediately. I was able to reproduce this 100% of the time a little while ago, but now I can't hit it at all anymore. :/  Another reporter sees this issue with Epiphany built from master and WebKitGTK+ 2.7.91. Backtrace attached, but it's from a release build.
Comment 1 Radar WebKit Bug Importer 2015-03-04 14:56:35 PST
<rdar://problem/20045591>
Comment 2 Joanmarie Diggs (irc: joanie) 2015-03-05 03:10:22 PST
See also bug 142333, which I'm seeing way more reliably than your accessibility-crash. But I've seen yours as well.
Comment 3 Michael Catanzaro 2015-03-08 16:34:13 PDT
A user in GNOME Bugzilla reports he can reproduce the problem with these steps:

1. Open Epiphany 
2. Go to URL http://www.lastfm.de/discover/
3. Enter a tag in the top-right search field. E.g. "cello"
4. Press enter key. Then press the big "=> Play" button.

(Though when I try that, I don't see any play button.)
Comment 4 Joanmarie Diggs (irc: joanie) 2015-03-16 11:45:46 PDT
Created attachment 248739 [details]
Patch
Comment 5 Joanmarie Diggs (irc: joanie) 2015-03-16 12:16:26 PDT
Chris: When you have a chance, I'd be grateful for a review. It's another one of those mostly-comments-and-changelogs patches. Thanks in advance!

p.s. Whatever's making my platform's bot unhappy is not my patch. ;)
Comment 6 chris fleizach 2015-03-16 16:14:29 PDT
Comment on attachment 248739 [details]
Patch

looks good thanks
Comment 7 WebKit Commit Bot 2015-03-16 17:12:42 PDT
Comment on attachment 248739 [details]
Patch

Clearing flags on attachment: 248739

Committed r181600: <http://trac.webkit.org/changeset/181600>
Comment 8 WebKit Commit Bot 2015-03-16 17:12:48 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Michael Catanzaro 2015-03-23 07:24:19 PDT
*** Bug 139284 has been marked as a duplicate of this bug. ***