We should make the namespace configurable for SOFT_LINK_*_{HEADER,SOURCE}() macros. And do a little clean-up at the same time, and some future support for Bug 141816.
Created attachment 246992 [details] Patch v1 (for EWS builds)
Attachment 246992 [details] did not pass style-queue: ERROR: Source/WebCore/platform/win/SoftLinking.h:206: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:316: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:329: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:334: Extra space before ( in function call [whitespace/parens] [4] Total errors found: 4 in 5 files If any of these errors are false positives, please file a bug against check-webkit-style.
Created attachment 246994 [details] Patch v2 (for EWS builds)
Attachment 246994 [details] did not pass style-queue: ERROR: Source/WebCore/platform/win/SoftLinking.h:206: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:316: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:329: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:334: Extra space before ( in function call [whitespace/parens] [4] Total errors found: 4 in 5 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 246994 [details] Patch v2 (for EWS builds) View in context: https://bugs.webkit.org/attachment.cgi?id=246994&action=review This looks good, but I feel like making the SOFT_LINK_NAMESPACE an argument to SOFT_LINK_FRAMEWORK, etc., might be simpler. But it's fine as-is. > Source/WebCore/platform/cf/CoreMediaSoftLink.cpp:36 > +SOFT_LINK_FRAMEWORK_SOURCE(CoreMedia) Why not just make SOFT_LINK_NAMESPACE an argument to SOFT_LINK_FRAMEWORK_{SOURCE, HEADER}?
Created attachment 246996 [details] Patch v3 (for EWS builds)
Comment on attachment 246996 [details] Patch v3 (for EWS builds) Same comments as before. Looks fine!
Attachment 246996 [details] did not pass style-queue: ERROR: Source/WebCore/platform/win/SoftLinking.h:197: SOFT_LINK_NAMESPACE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WebCore/platform/win/SoftLinking.h:207: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:316: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:330: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:335: Extra space before ( in function call [whitespace/parens] [4] Total errors found: 5 in 5 files If any of these errors are false positives, please file a bug against check-webkit-style.
(In reply to comment #5) > Comment on attachment 246994 [details] > Patch v2 (for EWS builds) > > View in context: > https://bugs.webkit.org/attachment.cgi?id=246994&action=review > > This looks good, but I feel like making the SOFT_LINK_NAMESPACE an argument > to SOFT_LINK_FRAMEWORK, etc., might be simpler. But it's fine as-is. > > > Source/WebCore/platform/cf/CoreMediaSoftLink.cpp:36 > > +SOFT_LINK_FRAMEWORK_SOURCE(CoreMedia) > > Why not just make SOFT_LINK_NAMESPACE an argument to > SOFT_LINK_FRAMEWORK_{SOURCE, HEADER}? It seemed like too much duplication to add that to every single call site. Let's chat in person, though!
(In reply to comment #9) > (In reply to comment #5) > > Comment on attachment 246994 [details] > > Patch v2 (for EWS builds) > > > > View in context: > > https://bugs.webkit.org/attachment.cgi?id=246994&action=review > > > > This looks good, but I feel like making the SOFT_LINK_NAMESPACE an argument > > to SOFT_LINK_FRAMEWORK, etc., might be simpler. But it's fine as-is. > > > > > Source/WebCore/platform/cf/CoreMediaSoftLink.cpp:36 > > > +SOFT_LINK_FRAMEWORK_SOURCE(CoreMedia) > > > > Why not just make SOFT_LINK_NAMESPACE an argument to > > SOFT_LINK_FRAMEWORK_{SOURCE, HEADER}? > > It seemed like too much duplication to add that to every single call site. > > Let's chat in person, though! I will go ahead and add an argument for the namespace for all the macros instead of doing the mysterious #define/#undefine of SOFT_LINK_NAMESPACE before landing.
Created attachment 247034 [details] Patch v4 (for landing; test EWS builds)
Attachment 247034 [details] did not pass style-queue: ERROR: Source/WebCore/platform/win/SoftLinking.h:205: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:315: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:328: Extra space before ( in function call [whitespace/parens] [4] ERROR: Source/WebCore/platform/mac/SoftLinking.h:333: Extra space before ( in function call [whitespace/parens] [4] Total errors found: 4 in 5 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 247034 [details] Patch v4 (for landing; test EWS builds) Looks great! r=me.
Committed r180476: <http://trac.webkit.org/changeset/180476>