Bug 141136 - AX: Focus Link Target (sequential focus navigation starting point)
Summary: AX: Focus Link Target (sequential focus navigation starting point)
Status: RESOLVED DUPLICATE of bug 116046
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
Keywords: InRadar
Depends on:
Reported: 2015-02-01 03:45 PST by Rodney Rehm
Modified: 2015-08-18 01:06 PDT (History)
2 users (show)

See Also:

test case (1.68 KB, text/html)
2015-02-01 03:45 PST, Rodney Rehm
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rodney Rehm 2015-02-01 03:45:31 PST
Created attachment 245826 [details]
test case

Steps to Reproduce:
1. define a non focusable element: <div id="the-target">
2. define a link to that element: <a href="#the-target">
3. click the link, hit <kbd>Tab</kbd> to see where focus ends up

Expected Behavior:
While the non focusable :target (<div id="the-target">) should not have received focus, it should be the element from which the next item in the document's tabbing sequence is identified upon pressing <kbd>Tab</kbd>

What Went Wrong:
Focus was retained on the link element, the tabbing sequence continues from there.

Related Bugs:

Chromium Bug For Reference:

Additional Notes:
"navigating to a fragment identifier" [1] defines what should happen when an anchor link is clicked. Using the "sequential focus navigation starting point" [2] is the way Gecko handles :target elements that are not focusable.

This behavior renders table of contents and skip-links useless, unless their :target elements are focusable.

[1] http://www.w3.org/TR/html5/browsers.html#scroll-to-fragid 
[2] https://html.spec.whatwg.org/multipage/interaction.html#sequential-focus-navigation-starting-point
Comment 1 Radar WebKit Bug Importer 2015-02-01 03:45:50 PST
Comment 2 Rodney Rehm 2015-02-01 03:54:05 PST
That first related bug should've been https://bugs.webkit.org/show_bug.cgi?id=22599
Comment 3 James Craig 2015-08-18 01:06:54 PDT
Dupe of bug 116046

*** This bug has been marked as a duplicate of bug 116046 ***