Bug 13864 - REGRESSION: Uninitialized value in RenderBlock::calcInlinePrefWidths()
: REGRESSION: Uninitialized value in RenderBlock::calcInlinePrefWidths()
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 523.x (Safari 3)
: All All
: P1 Normal
Assigned To: Nobody
: InRadar, Regression, ReviewedForRadar
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-24 13:44 PDT by Eli Fidler
Modified: 2008-08-24 02:19 PDT (History)
7 users (show)

See Also:


Attachments
All-whitespace text test case (577 bytes, text/html)
2007-08-17 08:25 PDT, mitz@webkit.org
no flags Details
Patch (1.56 KB, patch)
2008-08-24 01:35 PDT, mitz@webkit.org
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eli Fidler 2007-05-24 13:44:28 PDT
For text blocks that are just whitespace and stripFrontSpaces=true, when checking if the block should be considered for breaking, beginWS and endWS are used, but are uninitialized (RenderBlock.cpp:3741).

They don't get initialized in RenderText::trimmedPrefWidths() since it returns early.

I'm not sure if such blocks should be considered for breaking, so I don't know what values to initialize beginWS and endWS to.
Comment 1 Dave Hyatt 2007-05-24 16:02:27 PDT
Confirming.  This is a regression from newly-added code.
Comment 2 mitz@webkit.org 2007-08-17 08:25:19 PDT
Created attachment 16009 [details]
All-whitespace text test case

I think the code in RenderBlock::calcInlinePrefWidths is wrong anyway as demonstrated by this test case.
Comment 3 Adele Peterson 2007-08-30 14:38:39 PDT
<rdar://problem/5451470>
Comment 4 Adele Peterson 2007-08-30 14:40:09 PDT
What kind of effects could we see on real-world sites from this bug?
Comment 5 mitz@webkit.org 2007-12-12 23:50:59 PST
*** Bug 16414 has been marked as a duplicate of this bug. ***
Comment 6 Ariya Hidayat 2008-05-15 12:14:53 PDT
*** Bug 19083 has been marked as a duplicate of this bug. ***
Comment 7 Mark Rowe (bdash) 2008-07-28 08:22:43 PDT
*** Bug 20194 has been marked as a duplicate of this bug. ***
Comment 8 mitz@webkit.org 2008-08-24 01:35:50 PDT
Created attachment 22959 [details]
Patch
Comment 9 mitz@webkit.org 2008-08-24 02:19:03 PDT
Fixed in <http://trac.webkit.org/changeset/35902>.