Bug 138397 - Web Inspector: Do not update Timeline Views if they are not visible
Summary: Web Inspector: Do not update Timeline Views if they are not visible
Status: RESOLVED DUPLICATE of bug 141293
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-11-04 18:24 PST by Joseph Pecoraro
Modified: 2015-02-08 00:14 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2014-11-04 18:24:25 PST
* SUMMARY
From Bug 138387 it seems the TimelineViews are updating even though they are not visible. This seems like a lot of unnecessary work and can slow down interacting with the other views in the inspector, especially on page loads.
Comment 1 Joseph Pecoraro 2014-11-04 18:25:07 PST
Maybe not all TimelineViews, perhaps just the OverviewTimelineView.
Comment 2 Radar WebKit Bug Importer 2014-11-04 18:25:26 PST
<rdar://problem/18876212>
Comment 3 Brian Burg 2015-02-08 00:14:48 PST

*** This bug has been marked as a duplicate of bug 141293 ***