Bug 13839 - [CSS] customize submit button, text-indent: -2px;
Summary: [CSS] customize submit button, text-indent: -2px;
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh Intel OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.typography.nl/_phpwcms_133...
Keywords: HasReduction
: 13840 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-05-23 05:24 PDT by Robert
Modified: 2008-02-13 03:15 PST (History)
2 users (show)

See Also:


Attachments
minimal test case (514 bytes, text/html)
2008-02-09 14:50 PST, Robert Blaut
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2007-05-23 05:24:00 PDT
• check http://www.typography.nl/_phpwcms_133/index.php?login_en
• look at the 'login' button ['l' is tofar to the left]
• text in button uses [CSS] 'text-indent: -2px;'. If not used in all other browsers, including IE6/win to far to the right.
• except Safari 2.0.4, it shows a standard button and Webkit 522+, it shows the text to far to the left.
Comment 1 David Kilzer (:ddkilzer) 2007-05-23 06:18:28 PDT
*** Bug 13840 has been marked as a duplicate of this bug. ***
Comment 2 Dave Hyatt 2007-05-23 13:52:41 PDT
I'm not sure that this is a bug.  The site sets border and padding to 0... so of course a negative text indent will make the text stick out of the button...
Comment 3 Robert 2007-05-29 00:27:00 PDT
(In reply to comment #2)
> I'm not sure that this is a bug.  The site sets border and padding to 0... so
> of course a negative text indent will make the text stick out of the button...
> 

It happens ONLY in this browser!
All other browsers [even IE] do it correctly!
Comment 4 Robert Blaut 2008-02-09 14:49:41 PST
(In reply to comment #3)
> (In reply to comment #2)
> > I'm not sure that this is a bug.  The site sets border and padding to 0... so
> > of course a negative text indent will make the text stick out of the button...
> > 
> 
> It happens ONLY in this browser!
> All other browsers [even IE] do it correctly!
> 

As Dave said above the behavior on the page is correct in Webkit. Also Opera behaves identically as Webkit. Firefox have problem with proper indentation text. Based on your page I create minimal test case to explain proper behavior.
Comment 5 Robert Blaut 2008-02-09 14:50:11 PST
Created attachment 19023 [details]
minimal test case
Comment 6 Robert 2008-02-13 03:04:56 PST
No Bug, but in the minimal test case it works fine in Webkit / Safari 3, but still not in for instance Camino, Opera all on a mac. Better find another workaround to solve this problem.
Comment 7 Robert Blaut 2008-02-13 03:15:38 PST
(In reply to comment #6)
> No Bug, but in the minimal test case it works fine in Webkit / Safari 3, but
> still not in for instance Camino, Opera all on a mac. Better find another
> workaround to solve this problem.
> 

I've tested the test case against the latest Opera 9.50 snapshot and it doesn't show red on the page. However Opera shows small 1px black vertical dash. Camino uses the same engine as Firefox so based on comment #4 it isn't surprise the test fails also Camino.