Bug 137877 - Move std::unique_ptr<>|make_unique<> to WebCore/page/scrolling
Summary: Move std::unique_ptr<>|make_unique<> to WebCore/page/scrolling
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Gyuyoung Kim
URL:
Keywords:
: 138203 (view as bug list)
Depends on:
Blocks: 128007
  Show dependency treegraph
 
Reported: 2014-10-20 04:27 PDT by Gyuyoung Kim
Modified: 2015-02-22 18:38 PST (History)
5 users (show)

See Also:


Attachments
Patch (20.42 KB, patch)
2014-10-20 04:28 PDT, Gyuyoung Kim
no flags Details | Formatted Diff | Diff
Patch (21.27 KB, patch)
2014-10-20 07:04 PDT, Gyuyoung Kim
no flags Details | Formatted Diff | Diff
Patch (8.36 KB, patch)
2015-02-22 05:04 PST, Gyuyoung Kim
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gyuyoung Kim 2014-10-20 04:27:11 PDT
SSIA
Comment 1 Gyuyoung Kim 2014-10-20 04:28:11 PDT
Created attachment 240110 [details]
Patch
Comment 2 Gyuyoung Kim 2014-10-20 07:04:17 PDT
Created attachment 240119 [details]
Patch
Comment 3 Darin Adler 2014-10-20 09:57:59 PDT
Comment on attachment 240119 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=240119&action=review

> Source/WebCore/page/scrolling/mac/ScrollingCoordinatorMac.mm:118
> -    OwnPtr<ScrollingStateTree> treeState = scrollingStateTree()->commit(LayerRepresentation::PlatformLayerRepresentation);
> +    std::unique_ptr<ScrollingStateTree> treeState = scrollingStateTree()->commit(LayerRepresentation::PlatformLayerRepresentation);

This doesn’t compile yet:

/Volumes/Data/EWS/WebKit/Source/WebCore/page/scrolling/mac/ScrollingCoordinatorMac.mm:119:31: error: no viable conversion from '__bind<void (WebCore::ThreadedScrollingTree::*)(std::__1::unique_ptr<WebCore::ScrollingStateTree, std::__1::default_delete<WebCore::ScrollingStateTree> >), WebCore::ThreadedScrollingTree *, WebCore::ScrollingStateTree *>' to 'std::function<void ()>'

I don’t know exactly what’s wrong.
Comment 4 Gyuyoung Kim 2014-12-24 08:11:26 PST
*** Bug 138203 has been marked as a duplicate of this bug. ***
Comment 5 Gyuyoung Kim 2015-02-22 05:04:25 PST
Created attachment 247082 [details]
Patch
Comment 6 WebKit Commit Bot 2015-02-22 18:38:36 PST
Comment on attachment 247082 [details]
Patch

Clearing flags on attachment: 247082

Committed r180493: <http://trac.webkit.org/changeset/180493>
Comment 7 WebKit Commit Bot 2015-02-22 18:38:42 PST
All reviewed patches have been landed.  Closing bug.