Bug 136355 - [EFL] Remove E_Dbus dependency
Summary: [EFL] Remove E_Dbus dependency
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit EFL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryuan Choi
URL:
Keywords:
: 101866 (view as bug list)
Depends on:
Blocks: 139120
  Show dependency treegraph
 
Reported: 2014-08-28 16:29 PDT by Ryuan Choi
Modified: 2015-05-19 21:53 PDT (History)
4 users (show)

See Also:


Attachments
WorkInProgress (15.97 KB, patch)
2014-08-28 18:28 PDT, Ryuan Choi
no flags Details | Formatted Diff | Diff
Patch (20.92 KB, patch)
2014-11-18 14:53 PST, Ryuan Choi
no flags Details | Formatted Diff | Diff
Patch (24.65 KB, patch)
2014-11-18 15:04 PST, Ryuan Choi
no flags Details | Formatted Diff | Diff
rebased (24.56 KB, patch)
2014-11-27 22:10 PST, Ryuan Choi
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryuan Choi 2014-08-28 16:29:44 PDT
Since EFL 1.8, E_Dbus is deprecated.

Now we depends E_Dbus because of Battery Status and we can use eldbus instead of E_Dbus for it.
Comment 1 Ryuan Choi 2014-08-28 18:28:53 PDT
Created attachment 237335 [details]
WorkInProgress
Comment 2 Ryuan Choi 2014-11-18 14:53:44 PST
Created attachment 241815 [details]
Patch
Comment 3 Ryuan Choi 2014-11-18 15:04:44 PST
Created attachment 241818 [details]
Patch
Comment 4 Ryuan Choi 2014-11-26 04:45:40 PST
gyuyoung, could you review this?
Comment 5 Gyuyoung Kim 2014-11-26 04:56:57 PST
Comment on attachment 241818 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=241818&action=review

Patch looks fine to me. However I feel I need to take a look this patch further. Let me do it tomorrow.

> Source/WebCore/platform/efl/BatteryProviderEfl.cpp:158
> +    if (type != 2) // BATTERY

I don't understand What does "// BATTERY" comment means.

> Source/WebCore/platform/efl/BatteryProviderEfl.cpp:181
> +        Eldbus_Object* object = eldbus_object_get(static_cast<BatteryProviderEfl*>(data)->connection(), BUS, path);

Don't we need to check if object is null ?
Comment 6 Ryuan Choi 2014-11-27 22:10:17 PST
Created attachment 242260 [details]
rebased
Comment 7 Ryuan Choi 2014-11-27 22:11:04 PST
(In reply to comment #5)
> Comment on attachment 241818 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=241818&action=review
> 
> Patch looks fine to me. However I feel I need to take a look this patch
> further. Let me do it tomorrow.
> 
> > Source/WebCore/platform/efl/BatteryProviderEfl.cpp:158
> > +    if (type != 2) // BATTERY
> 
> I don't understand What does "// BATTERY" comment means.
> 
> > Source/WebCore/platform/efl/BatteryProviderEfl.cpp:181
> > +        Eldbus_Object* object = eldbus_object_get(static_cast<BatteryProviderEfl*>(data)->connection(), BUS, path);
> 
> Don't we need to check if object is null ?

Sure, rebased with what you addressed.
Comment 8 Gyuyoung Kim 2014-11-27 22:12:47 PST
Comment on attachment 242260 [details]
rebased

LGTM.
Comment 9 WebKit Commit Bot 2014-11-27 23:03:54 PST
Comment on attachment 242260 [details]
rebased

Clearing flags on attachment: 242260

Committed r176555: <http://trac.webkit.org/changeset/176555>
Comment 10 WebKit Commit Bot 2014-11-27 23:04:00 PST
All reviewed patches have been landed.  Closing bug.
Comment 11 Ryuan Choi 2015-05-19 21:53:03 PDT
*** Bug 101866 has been marked as a duplicate of this bug. ***