Bug 136089 - [EFL][JSC] Disassembly not available on ARM64
Summary: [EFL][JSC] Disassembly not available on ARM64
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 126352 (view as bug list)
Depends on:
Blocks: 108645
  Show dependency treegraph
 
Reported: 2014-08-19 18:17 PDT by Akos Kiss
Modified: 2015-01-28 11:12 PST (History)
12 users (show)

See Also:


Attachments
Proposed patch. (4.63 KB, patch)
2014-08-19 18:36 PDT, Akos Kiss
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Akos Kiss 2014-08-19 18:17:10 PDT
When running jsc with "--showDisassembly=true --showDFGDisassembly=true" on EFL/ARM64, the output contains only "disassembly not available for range ..." lines in place of the disassembled instructions.
Comment 1 Akos Kiss 2014-08-19 18:36:24 PDT
Created attachment 236845 [details]
Proposed patch.
Comment 2 WebKit Commit Bot 2014-08-20 10:59:25 PDT
Comment on attachment 236845 [details]
Proposed patch.

Clearing flags on attachment: 236845

Committed r172799: <http://trac.webkit.org/changeset/172799>
Comment 3 WebKit Commit Bot 2014-08-20 10:59:29 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Brendan Long 2015-01-28 11:12:37 PST
*** Bug 126352 has been marked as a duplicate of this bug. ***