Bug 13465 - REGRESSION (r20972): Wall Street Journal pages replaced by advertisements
Summary: REGRESSION (r20972): Wall Street Journal pages replaced by advertisements
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://wsj.com
Keywords: InRadar, NeedsReduction, Regression
: 13590 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-04-23 19:07 PDT by Geoffrey F. Green
Modified: 2007-05-12 23:24 PDT (History)
3 users (show)

See Also:


Attachments
Screenshot of WSJ home page rendered on latest nightly (54.37 KB, image/png)
2007-04-23 19:08 PDT, Geoffrey F. Green
no flags Details
Screenshot of part of WSJ home page rendered on 419.3 (57.49 KB, image/png)
2007-04-23 19:09 PDT, Geoffrey F. Green
no flags Details
Screenshot of history list from r21368 (47.13 KB, image/png)
2007-05-10 12:30 PDT, Geoffrey F. Green
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey F. Green 2007-04-23 19:07:38 PDT
A Javascript which (as far as i can tell) assists in acquiring a series of text advertisements placed in an iframe on Wall Street Journal pages (I've checked article pages and the front page so far) works properly in release versions of Safari, Firefox and Camino but fails in the latest nightly. Instead of inserting the text into an iframe on the page, WebKit replaces the page with the ads. It makes the Wall Street Journal site unusable. I'll attach screenshots from the latest nightly and 419.3 (which renders properly).
Comment 1 Geoffrey F. Green 2007-04-23 19:08:53 PDT
Created attachment 14151 [details]
Screenshot of WSJ home page rendered on latest nightly
Comment 2 Geoffrey F. Green 2007-04-23 19:09:39 PDT
Created attachment 14152 [details]
Screenshot of part of WSJ home page rendered on 419.3

The screenshot shows the advertising block which is near the bottom of the WSJ home page.
Comment 3 Alexey Proskuryakov 2007-04-23 21:34:19 PDT
Confirmed with r21002.
Comment 4 Alexey Proskuryakov 2007-04-25 01:55:58 PDT
I suspect <http://trac.webkit.org/projects/webkit/changeset/20972> (<rdar://problem/4671964> document property on <iframe> elements causes problems for SAP application).
Comment 5 Darin Adler 2007-04-25 10:39:12 PDT
<rdar://problem/5159541>
Comment 6 Darin Adler 2007-04-28 00:23:17 PDT
The problem seems to be that contentDocument and contentWindow are both undefined on new frame elements until they've done enough loading to go from the provisional state to the committed state.
Comment 7 Darin Adler 2007-04-28 00:24:37 PDT
There's code that looks at contentDocument and contentWindow first, then falls back to other properties, including document. It would work fine if contentDocument or contentWindow was defined.
Comment 8 Darin Adler 2007-04-28 00:26:05 PDT
The function is changeIframeSrc and it's in http://online.wsj.com/javascript/commonFunctions.js
Comment 9 Alexey Proskuryakov 2007-05-04 23:49:45 PDT
*** Bug 13590 has been marked as a duplicate of this bug. ***
Comment 10 Geoffrey F. Green 2007-05-10 12:30:01 PDT
Fixed in r21368 (change 21367) except that the browser history includes, as a separate entry, the iframe that previously replaced the document. In other words, using the sample error, the proper WSJ page is displayed, but the history list includes both the WSJ page and the title of the iframe page.  Selecting the "iframe entry" from the history list sends you to the iframe.  To clarify, see image of history list below.
Comment 11 Geoffrey F. Green 2007-05-10 12:30:50 PDT
Created attachment 14475 [details]
Screenshot of history list from r21368
Comment 12 Darin Adler 2007-05-10 12:36:46 PDT
(In reply to comment #10)
> Fixed in r21368 (change 21367) except that the browser history includes, as a
> separate entry, the iframe that previously replaced the document. In other
> words, using the sample error, the proper WSJ page is displayed, but the
> history list includes both the WSJ page and the title of the iframe page. 
> Selecting the "iframe entry" from the history list sends you to the iframe.  To
> clarify, see image of history list below.

Lets make a new bug report about this smaller anomaly so we can close this one and put the focus clearly on understanding the cause of the remaining behavior.
Comment 13 David Kilzer (:ddkilzer) 2007-05-12 23:24:42 PDT
(In reply to comment #12)
> Lets make a new bug report about this smaller anomaly so we can close this one
> and put the focus clearly on understanding the cause of the remaining behavior.

Followup is Bug 13686.  Closing this bug per Comment #10.