Bug 13395 - REGRESSION: Overlapping text when viewing Yahoo! Mail message (due to use of naturalHeight/Width)
Summary: REGRESSION: Overlapping text when viewing Yahoo! Mail message (due to use of ...
Status: RESOLVED DUPLICATE of bug 13333
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2007-04-18 09:57 PDT by David Kilzer (:ddkilzer)
Modified: 2007-04-19 13:34 PDT (History)
2 users (show)

See Also:


Attachments
Unreduced test case (97.82 KB, application/x-gzip)
2007-04-18 09:58 PDT, David Kilzer (:ddkilzer)
no flags Details
Screenshot (153.84 KB, image/png)
2007-04-18 09:59 PDT, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2007-04-18 09:57:12 PDT
* SUMMARY
Overlapping text is drawn when viewing certain messages through Yahoo! Mail.

* STEPS TO REPRODUCE
1. Open Safari/WebKit.
2. Open attached test case (after unarchiving) in Safari/WebKit.
3. If overlapping text is not seen, reload page (once or twice).

* EXPECTED RESULTS
The page should render without overlapping text.

* ACTUAL RESULTS
The page renders with overlapping text.

* REGRESSION
This is a regression from shipping Safari 2.0.4 (419.3) on Mac OS X 10.4.9 (8P135).  Seen with a local debug build of WebKit r20930.

* NOTES
See attached screenshot and test case.  My apologies for not reducing this test case first.  (Hopefully there are no Yahoo! sekrits in the page!)
Comment 1 David Kilzer (:ddkilzer) 2007-04-18 09:58:23 PDT
Created attachment 14075 [details]
Unreduced test case

Unreduced test case.
Comment 2 David Kilzer (:ddkilzer) 2007-04-18 09:59:24 PDT
Created attachment 14076 [details]
Screenshot

Screenshot of issue.
Comment 3 mitz 2007-04-18 12:40:29 PDT
The imgsDone function on the page, intended for use with Firefox, always returns 'true' in WebKit since naturalWidth and naturalHeight are not supported. As a result, the rmvScroll function proceeds to adjust the layout based on incorrect image dimensions. This goes unnoticed in Safari 2.0.4 because of a JavaScript error (probably due to incomplete CSS object model support), but in TOT rmvScroll completes successfully, which results in the incorrect layout.

If bug 13333 is not addressed, Yahoo will need to use a different technique to tell if images have loaded.
Comment 4 David Kilzer (:ddkilzer) 2007-04-19 13:34:22 PDT
Fixed by Bug 13333.



*** This bug has been marked as a duplicate of 13333 ***