Bug 13333 - Support naturalWidth/naturalHeight on image elements
Summary: Support naturalWidth/naturalHeight on image elements
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
: 13395 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-04-11 11:45 PDT by Anders Carlsson
Modified: 2007-04-19 13:34 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2007-04-11 11:45:32 PDT
These return the real width and height of the image, and not the width specified by CSS or attributes
Comment 1 David Kilzer (:ddkilzer) 2007-04-19 05:27:52 PDT
This may be P1 depending on if Bug 13395 is resolved by Yahoo! or not.

Comment 2 Darin Adler 2007-04-19 10:27:12 PDT
I think this is the best way to fix the Yahoo problem in bug 13395; it should be relatively straightforward to do.
Comment 3 Anders Carlsson 2007-04-19 10:34:37 PDT
I've implemented this, just need to write a layout test.
Comment 4 Darin Adler 2007-04-19 10:38:37 PDT
Oh, OK. Too bad you didn't assign to yourself. I was just working on it too!
Comment 5 Darin Adler 2007-04-19 10:39:14 PDT
My research indicates that these should return 0 when there is not a currently-loaded image.
Comment 6 Anders Carlsson 2007-04-19 11:27:36 PDT
Darn, I just accepted the bug without reassigning it to myself, sorry about that.
Comment 7 Anders Carlsson 2007-04-19 12:38:46 PDT
Committed revision 20954.
Comment 8 David Kilzer (:ddkilzer) 2007-04-19 13:34:22 PDT
*** Bug 13395 has been marked as a duplicate of this bug. ***