Bug 133634 - WebGL WEBGL_draw_buffers missing (iOS and Desktop)
Summary: WebGL WEBGL_draw_buffers missing (iOS and Desktop)
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: 528+ (Nightly build)
Hardware: iPhone / iPad Unspecified
: P2 Normal
Assignee: Nobody
URL: http://www.khronos.org/registry/webgl...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-08 22:36 PDT by Florian Bösch
Modified: 2016-02-29 17:24 PST (History)
10 users (show)

See Also:


Attachments
patch (2.07 KB, patch)
2014-12-10 13:12 PST, Roger Fong
bfulgham: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Bösch 2014-06-08 22:36:28 PDT
The WebGL extension WEBGL_draw_buffers is missing on iOS8. Possibly a merge task/regression.

Related ticket (rename from EXT to WEBGL): https://bugs.webkit.org/show_bug.cgi?id=128894
Specification: http://www.khronos.org/registry/webgl/extensions/WEBGL_draw_buffers/
Comment 1 Florian Bösch 2014-06-18 00:19:09 PDT
iOS8 Beta 2 is still missing WEBGL_draw_buffers. They're also missing on desktop safari. Firefox implements this feature on OSX, Linux and Android. Chrome implements it on OSX and Linux.
Comment 2 Roger Fong 2014-12-10 13:07:45 PST
rdar://problem/15949588
Comment 3 Roger Fong 2014-12-10 13:12:10 PST
Created attachment 243061 [details]
patch
Comment 4 Roger Fong 2014-12-10 13:42:10 PST
The implementation for this was already done before but was not switched on due to underlying driver bugs which have now been resolved. Flipping on the switch.
Comment 5 Brent Fulgham 2014-12-10 13:44:27 PST
Comment on attachment 243061 [details]
patch

r=me.
Comment 6 Brent Fulgham 2014-12-10 13:45:39 PST
(In reply to comment #5)
> Comment on attachment 243061 [details]
> patch
> 
> r=me.

We might want to either confirm drivers at runtime, or limit this to specific OS revisions.
Comment 8 Marcin Ignac 2016-02-29 17:24:14 PST
WEBGL_draw_buffers is still not available on iOS 9.2.1. Are there any plans to push it?