Bug 132960 - [GTK] generate-forwarding-headers.pl must run before compiling sources
Summary: [GTK] generate-forwarding-headers.pl must run before compiling sources
Status: RESOLVED DUPLICATE of bug 137207
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 132956
  Show dependency treegraph
 
Reported: 2014-05-15 09:42 PDT by Martin Hodovan
Modified: 2014-09-29 06:10 PDT (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Hodovan 2014-05-15 09:42:54 PDT
Bug 132956: [WK2] Change the remaining framework includes from WebKit2 to WebKit
https://bugs.webkit.org/show_bug.cgi?id=132956


  Comment #3 From Csaba Osztrogonác 2014-05-15 08:46:55 PST
    It seems GTK's cmake system is buggy:
    Source/WebKit2/Scripts/generate-forwarding-headers.pl

    [snip]

      In file included from ../../Tools/TestWebKitAPI/gtk/main.cpp:26:0:
      ../../Tools/TestWebKitAPI/config.h:68:30: fatal error: WebKit/WebKit2_C.h: No such file or directory

      In file included from ../../Tools/TestWebKitAPI/TestsController.cpp:26:0:
      ../../Tools/TestWebKitAPI/config.h:68:30: fatal error: WebKit/WebKit2_C.h: No such file or directory

      In file included from ../../Tools/TestWebKitAPI/Tests/JavaScriptCore/VMInspector.cpp:26:0:
      ../../Tools/TestWebKitAPI/config.h:68:30: fatal error: WebKit/WebKit2_C.h: No such file or directory

    [snip]

    [Creating forwarding header for WebKit/UIProcess/API/C/WebKit2_C.h]

    -----

    generate-forwarding-headers.pl must run before everything else.
    This dependency should be fixed, because it can cause flakey build failures.
Comment 1 Csaba Osztrogonác 2014-05-16 02:05:54 PDT
I landed the patch from Bug132956, because this bug is absolutely
independent from that one - http://trac.webkit.org/changeset/168961.

As far as I thought, it caused build failures on the GTK bots:
- http://build.webkit.org/builders/GTK%20Linux%2032-bit%20Release/builds/44026
- http://build.webkit.org/builders/GTK%20Linux%2064-bit%20Release%20%28Build%29/builds/47525
- http://build.webkit.org/builders/GTK%20Linux%2064-bit%20Debug%20%28Build%29/builds/42226

But the next build worked fine after the first generated the forwarding headers.
Comment 2 Carlos Alberto Lopez Perez 2014-05-16 07:51:50 PDT
(In reply to comment #1)
> But the next build worked fine after the first generated the forwarding headers.

Indeed. I just compiled webkitgtk+ here locally and it failed as you describe:

In file included from ../../Tools/TestWebKitAPI/gtk/main.cpp:26:0:
../../Tools/TestWebKitAPI/config.h:68:30: fatal error: WebKit/WebKit2_C.h: No such file or directory
 #include <WebKit/WebKit2_C.h>
                              ^
compilation terminated.


I retried the compilation a second time and it worked fine.
Comment 3 Alberto Garcia 2014-05-21 05:40:15 PDT
Does this happen with make, ninja or both?
Comment 4 Sergio Villar Senin 2014-05-27 09:06:31 PDT
(In reply to comment #3)
> Does this happen with make, ninja or both?

With build-webkit.sh this happen for sure. It's impossible to build wk by just using the build script. You need to call ninja to have the forwarding headers generated.
Comment 5 Alberto Garcia 2014-05-27 09:35:56 PDT
(In reply to comment #4)
> > Does this happen with make, ninja or both?
>
> With build-webkit.sh this happen for sure.

Yes but this will use make or ninja depending on what's installed. My
question is with which one you were reproducing this problem.
Comment 6 Sergio Villar Senin 2014-05-27 09:47:26 PDT
(In reply to comment #5)
> (In reply to comment #4)
> > > Does this happen with make, ninja or both?
> >
> > With build-webkit.sh this happen for sure.
> 
> Yes but this will use make or ninja depending on what's installed. My
> question is with which one you were reproducing this problem.

It should be using ninja
Comment 7 Csaba Osztrogonác 2014-09-29 06:10:50 PDT

*** This bug has been marked as a duplicate of bug 137207 ***