Bug 132224 - Webpages can trigger loads with invalid URLs
Summary: Webpages can trigger loads with invalid URLs
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Darin Adler
URL:
Keywords: InRadar
: 130894 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-26 20:37 PDT by Darin Adler
Modified: 2018-09-13 09:47 PDT (History)
8 users (show)

See Also:


Attachments
Patch (18.29 KB, patch)
2014-04-26 20:44 PDT, Darin Adler
ap: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2014-04-26 20:37:23 PDT
Webpages can trigger loads with invalid URLs
Comment 1 Darin Adler 2014-04-26 20:44:33 PDT
Created attachment 230252 [details]
Patch
Comment 2 David Kilzer (:ddkilzer) 2014-04-27 01:07:59 PDT
(In reply to comment #1)
> Created an attachment (id=230252) [details]
> Patch

I think this patch may be missing changes that were landed by accident in r167851 for Bug 132089:

<http://trac.webkit.org/changeset/167851>
Comment 3 David Kilzer (:ddkilzer) 2014-04-27 01:21:24 PDT
(In reply to comment #2)
> (In reply to comment #1)
> > Created an attachment (id=230252) [details] [details]
> > Patch
> 
> I think this patch may be missing changes that were landed by accident in r167851 for Bug 132089:
> 
> <http://trac.webkit.org/changeset/167851>

These changes were rolled out in r167852:

<http://trac.webkit.org/changeset/167852>
Comment 4 Darin Adler 2014-04-27 09:05:58 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #1)
> > I think this patch may be missing changes that were landed by accident in r167851 for Bug 132089:
> > 
> > <http://trac.webkit.org/changeset/167851>
> 
> These changes were rolled out in r167852:
> 
> <http://trac.webkit.org/changeset/167852>

Those changes were from a different try at fixing this bug; they are not needed.
Comment 5 Darin Adler 2014-04-27 09:06:52 PDT
Committed r167856: <http://trac.webkit.org/changeset/167856>
Comment 6 Renata Hodovan 2014-04-28 07:03:23 PDT
*** Bug 130894 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Bates 2014-06-11 10:03:00 PDT
<rdar://problem/16697142>
Comment 8 Daniel Bates 2014-06-17 12:43:37 PDT
(In reply to comment #5)
> Committed r167856: <http://trac.webkit.org/changeset/167856>

This change regressed the HSBC app. See bug #133991 for more details.