Bug 131881 - REGRESSION (r167530): fast/dom/gc-attribute-node.html is failing on Mac
Summary: REGRESSION (r167530): fast/dom/gc-attribute-node.html is failing on Mac
Status: RESOLVED DUPLICATE of bug 88045
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: LayoutTestFailure, PlatformOnly
Depends on:
Blocks:
 
Reported: 2014-04-18 21:57 PDT by Timothy Hatcher
Modified: 2014-04-20 22:59 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Hatcher 2014-04-18 21:57:06 PDT
It has been failing on Windows (bug 127480).
Comment 1 Timothy Hatcher 2014-04-18 23:06:05 PDT
Marked as flaky in https://trac.webkit.org/r167531.
Comment 2 Alexey Proskuryakov 2014-04-18 23:12:35 PDT
Could you please post a diff? Looking at flakiness dashboard, I don't see this test having ever failed.
Comment 3 Timothy Hatcher 2014-04-18 23:14:33 PDT
It started flaking with my patch in https://trac.webkit.org/r167530. Not really sure why. My change is unrelated to the tested code.
Comment 4 Alexey Proskuryakov 2014-04-20 15:41:06 PDT
Could be memory corruption from
Comment 5 Timothy Hatcher 2014-04-20 21:05:51 PDT
From?
Comment 6 Alexey Proskuryakov 2014-04-20 22:59:01 PDT
I wanted to conjecture memory corruption from a previous test, but that's not accurate.

Turns out that custom attributes on attribute nodes are broken in JSC. We used to know that and to expect a failure, until Filip's patch <http://trac.webkit.org/changeset/159705> slightly changed memory layout, so the test started to pass accidentally. He then removed the failing expectation.

But there was no real fix, and now your patch slightly changed memory layout again, making the test fail again.

*** This bug has been marked as a duplicate of bug 88045 ***