Bug 131212 - REGRESSION (r166615): Pressing return doesn’t submit search term at bing.com
Summary: REGRESSION (r166615): Pressing return doesn’t submit search term at bing.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: Alexey Proskuryakov
URL: http://bing.com
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2014-04-03 23:19 PDT by mitz
Modified: 2014-04-04 11:08 PDT (History)
1 user (show)

See Also:


Attachments
proposed fix (6.93 KB, patch)
2014-04-04 10:58 PDT, Alexey Proskuryakov
mitz: review+
Details | Formatted Diff | Diff
proposed fix (7.01 KB, patch)
2014-04-04 11:02 PDT, Alexey Proskuryakov
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2014-04-03 23:19:26 PDT
To reproduce this bug, navigate to the Bing homepage or a Bing search results page, type something in the Bing search field, and press return. Nothing happens.

This is the regression range: <http://trac.webkit.org/log/trunk/?rev=166621&stop_rev=166612>. I strongly suspect <http://trac.webkit.org/r166615>, the fix for bug 131055.
Comment 1 mitz 2014-04-03 23:24:47 PDT
Confirmed that this was caused by r166615.
Comment 2 mitz 2014-04-03 23:26:59 PDT
<rdar://problem/16521788>
Comment 3 Alexey Proskuryakov 2014-04-04 10:58:47 PDT
Created attachment 228607 [details]
proposed fix
Comment 4 Alexey Proskuryakov 2014-04-04 11:02:22 PDT
Created attachment 228608 [details]
proposed fix

Let's not a revert a FIXME.
Comment 5 Alexey Proskuryakov 2014-04-04 11:08:35 PDT
Committed <http://trac.webkit.org/r166793>.