Bug 13046 - CSS styles on hover and focus are broken for <use>
Summary: CSS styles on hover and focus are broken for <use>
Status: RESOLVED DUPLICATE of bug 12838
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2007-03-12 07:57 PDT by jay
Modified: 2007-03-17 08:53 PDT (History)
1 user (show)

See Also:


Attachments
demonstrates styles changes though broken for <use> (1.62 KB, image/svg+xml)
2007-03-12 07:58 PDT, jay
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description jay 2007-03-12 07:57:18 PDT
hover over the icon in the attachment.
or use tab button to move focus to icon in attachment

style of text and circle are changed and now visible.
however style of "border" which is <use> has not changed.
CSS rules specify it should  have.
compare with Opera or mozilla where style changes.

maybe related to http://bugs.webkit.org/show_bug.cgi?id=7555

please move to CSS if that is the correct component.
Comment 1 jay 2007-03-12 07:58:10 PDT
Created attachment 13590 [details]
demonstrates styles changes though broken for <use>
Comment 2 jay 2007-03-16 14:07:05 PDT
less than a month and I'm already filing dupes.
~:"

*** This bug has been marked as a duplicate of 12838 ***
Comment 3 Nikolas Zimmermann 2007-03-17 08:53:35 PDT
Fixed - landed in r20262.