Bug 12838 - SVG <use> CSS styles broken
Summary: SVG <use> CSS styles broken
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nikolas Zimmermann
URL: http://www.peepo.co.uk
Keywords: HasReduction
: 13046 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-02-21 02:08 PST by jay
Modified: 2007-03-17 12:35 PDT (History)
2 users (show)

See Also:


Attachments
script test case (1.25 KB, image/svg+xml)
2007-02-21 02:09 PST, jay
no flags Details
CSS broken for <use> (3.29 KB, image/svg+xml)
2007-03-13 03:06 PDT, jay
no flags Details
Initial patch (37.03 KB, patch)
2007-03-17 06:26 PDT, Nikolas Zimmermann
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jay 2007-02-21 02:08:23 PST
mouseover the small circle, a hidden group with three circles should appear.

Only one does, the other two are defined by <use> elements
Comment 1 jay 2007-02-21 02:09:14 PST
Created attachment 13291 [details]
script test case
Comment 2 Nikolas Zimmermann 2007-03-01 10:07:33 PST

*** This bug has been marked as a duplicate of 12936 ***
Comment 3 jay 2007-03-13 02:43:34 PDT
remains broken, patch on bug 12936 ineffective.
Comment 4 jay 2007-03-13 03:06:16 PDT
Created attachment 13607 [details]
CSS broken for <use>
Comment 5 jay 2007-03-13 03:11:55 PDT
mouse over the two icons in attachment 'CSS broken'

in both cases the text appears, however in the <use> case styles don't change. in particular visibility of classes rt and st for #gamesBorder and #sound don't change. this is general to css styles and not particular to visibility.

compare with circles whose styles do change.

check with mozilla or opera nightly to see appropriate activity.
Comment 6 jay 2007-03-16 14:07:05 PDT
*** Bug 13046 has been marked as a duplicate of this bug. ***
Comment 7 Nikolas Zimmermann 2007-03-17 06:26:56 PDT
Created attachment 13681 [details]
Initial patch

One-liner fixing all current CSS & <use> problems.
Forgot to pass down the StyleChange parameter to the shadow tree root element, when calling recalcStyle.

Added new test case based on css-events-webkit.svg. Thanks for the nice testcase!
Comment 8 Sam Weinig 2007-03-17 08:48:28 PDT
Comment on attachment 13681 [details]
Initial patch

r=me!
Comment 9 Nikolas Zimmermann 2007-03-17 08:53:43 PDT
Fixed - landed in r20262.
Comment 10 jay 2007-03-17 12:35:44 PDT
#7

slightly embarrased, sheepish grin.
I like to provide tight test cases and this one isn't that...
apologies,