Bug 129565 - Remove filterRes parameter from filters
Summary: Remove filterRes parameter from filters
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar, WebExposed
: 124914 (view as bug list)
Depends on:
Blocks: 68469
  Show dependency treegraph
 
Reported: 2014-03-01 17:27 PST by Adenilson Cavalcanti Silva
Modified: 2018-09-24 17:40 PDT (History)
10 users (show)

See Also:


Attachments
test-page to show effect of filterRes on retina clients (570.36 KB, application/octet-stream)
2015-12-08 09:27 PST, Felix Hassert
no flags Details
Patch (580.05 KB, patch)
2018-09-23 10:47 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews100 for mac-sierra (2.63 MB, application/zip)
2018-09-23 11:54 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews104 for mac-sierra-wk2 (3.20 MB, application/zip)
2018-09-23 12:06 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews202 for win-future (12.97 MB, application/zip)
2018-09-23 12:30 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews116 for mac-sierra (3.29 MB, application/zip)
2018-09-23 12:49 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews121 for ios-simulator-wk2 (2.55 MB, application/zip)
2018-09-23 12:53 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews113 for mac-sierra (3.24 MB, application/zip)
2018-09-23 14:46 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews123 for ios-simulator-wk2 (2.57 MB, application/zip)
2018-09-23 15:35 PDT, Build Bot
no flags Details
Patch (661.32 KB, patch)
2018-09-23 20:18 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews202 for win-future (12.94 MB, application/zip)
2018-09-23 22:03 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews121 for ios-simulator-wk2 (2.47 MB, application/zip)
2018-09-23 22:24 PDT, Build Bot
no flags Details
Patch (665.12 KB, patch)
2018-09-23 22:31 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adenilson Cavalcanti Silva 2014-03-01 17:27:23 PST
It seems that filterRes is deprecated in the spec (http://dev.w3.org/fxtf/filters/). Quote: "... filterRes attribute was removed from the specification. See SVG 1.1 specification for the definition". Finally FF has removed it already.

It makes sense to remove this feature.
Comment 1 Dirk Schulze 2014-03-02 08:35:35 PST
*** Bug 124914 has been marked as a duplicate of this bug. ***
Comment 2 Felix Hassert 2015-12-08 09:24:58 PST
I stumbled upon very similar problems with SVG Filters that are rendered in Safari in viewport pixels, disregarding device pixels on 'retina' devices. This was reported in Bug 124914 and in a somewhat related discussion in Bug 93471.

I am also using filterRes to get sharp images on retina images. I have a test-page attached.

The HTML is:

<img src="filtered.svg" width="400">

and filtered.svg has a width of 800px for clients with DPR=2. as soon as a filter is used in the SVG it appears blurry in the browser.

i can fix that by repeating the (desired) dimensions as filterRes in the svg:

<svg ....  width="800" height="531" ...>
.. 
  <filter filterRes="800 531" id="noop">
...

I don't know of any other workaround to make filters apply on a canvas regarding the dpr. If there is a better and more compliant way, please let me know.

However, as long as I need this workaround, I would like to discourage you to drop filterRes.

That said, I think that it is a bug in webkit, that the actual canvas size for filters is (presumably) derived from the targeted viewport area. Other browsers (Chrome and Firefox) that have already dropped filterRes support do not show this behavior. Please use the attached test-page svg-filter.tgz to verify it.
Comment 3 Felix Hassert 2015-12-08 09:27:34 PST
Created attachment 266897 [details]
test-page to show effect of filterRes on retina clients
Comment 4 Radar WebKit Bug Importer 2018-09-23 10:22:56 PDT
<rdar://problem/44714340>
Comment 5 Simon Fraser (smfr) 2018-09-23 10:47:51 PDT
Created attachment 350573 [details]
Patch
Comment 6 Build Bot 2018-09-23 11:54:16 PDT Comment hidden (obsolete)
Comment 7 Build Bot 2018-09-23 11:54:18 PDT Comment hidden (obsolete)
Comment 8 Build Bot 2018-09-23 12:06:23 PDT Comment hidden (obsolete)
Comment 9 Build Bot 2018-09-23 12:06:25 PDT Comment hidden (obsolete)
Comment 10 Build Bot 2018-09-23 12:30:02 PDT Comment hidden (obsolete)
Comment 11 Build Bot 2018-09-23 12:30:14 PDT Comment hidden (obsolete)
Comment 12 Build Bot 2018-09-23 12:49:35 PDT Comment hidden (obsolete)
Comment 13 Build Bot 2018-09-23 12:49:36 PDT Comment hidden (obsolete)
Comment 14 Build Bot 2018-09-23 12:53:20 PDT Comment hidden (obsolete)
Comment 15 Build Bot 2018-09-23 12:53:22 PDT Comment hidden (obsolete)
Comment 16 Build Bot 2018-09-23 14:46:06 PDT Comment hidden (obsolete)
Comment 17 Build Bot 2018-09-23 14:46:08 PDT Comment hidden (obsolete)
Comment 18 Build Bot 2018-09-23 15:35:33 PDT Comment hidden (obsolete)
Comment 19 Build Bot 2018-09-23 15:35:35 PDT Comment hidden (obsolete)
Comment 20 Simon Fraser (smfr) 2018-09-23 20:18:58 PDT
Created attachment 350601 [details]
Patch
Comment 21 Build Bot 2018-09-23 22:03:02 PDT Comment hidden (obsolete)
Comment 22 Build Bot 2018-09-23 22:03:14 PDT Comment hidden (obsolete)
Comment 23 Build Bot 2018-09-23 22:24:57 PDT Comment hidden (obsolete)
Comment 24 Build Bot 2018-09-23 22:24:59 PDT Comment hidden (obsolete)
Comment 25 Simon Fraser (smfr) 2018-09-23 22:31:22 PDT
Created attachment 350608 [details]
Patch
Comment 26 WebKit Commit Bot 2018-09-24 17:40:22 PDT
Comment on attachment 350608 [details]
Patch

Clearing flags on attachment: 350608

Committed r236447: <https://trac.webkit.org/changeset/236447>
Comment 27 WebKit Commit Bot 2018-09-24 17:40:24 PDT
All reviewed patches have been landed.  Closing bug.