Bug 12893 - Horizontal scrollbar present during incremental rendering does not repaint after being removed
: Horizontal scrollbar present during incremental rendering does not repaint af...
Status: RESOLVED DUPLICATE of bug 11224
: WebKit
Layout and Rendering
: 523.x (Safari 3)
: Macintosh Mac OS X 10.4
: P2 Major
Assigned To:
: http://petitions.pm.gov.uk/Open-IT-pr...
:
:
:
  Show dependency treegraph
 
Reported: 2007-02-26 04:01 PST by
Modified: 2007-02-26 05:05 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-26 04:01:28 PST
Steps to reproduce:
1. Load http://petitions.pm.gov.uk/Open-IT-projects/ on a slow-ish network connection.
2. Note that a horizontal scrollbar appears during the page load.
3. Scroll down the page.

The horizontal scrollbar remains fixed to the content and detaches from the bottom of the screen.  Drag a selection through the scrollbar to notice that the area repaints correctly.

This doesn't reproduce when i reload the page after is already loaded.  This appears to be due to some resources being cached so the initial layout takes place at a different time.
------- Comment #1 From 2007-02-26 05:05:17 PST -------
See also bug 8909 and a comment on why I think this is happening under bug 12440.

*** This bug has been marked as a duplicate of 11224 ***