Bug 11224 - Scrollbar remnant @ msnbc.msn.com
Summary: Scrollbar remnant @ msnbc.msn.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://msnbc.msn.com/id/15172758/?GT1...
Keywords:
: 11563 12893 13023 13816 13949 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-08 20:54 PDT by Geoffrey Garen
Modified: 2013-06-04 11:20 PDT (History)
10 users (show)

See Also:


Attachments
Screenshot (45.09 KB, image/png)
2006-10-08 20:54 PDT, Geoffrey Garen
no flags Details
Screenshot of the stale scrollbar on Redfin. (879.49 KB, image/png)
2011-07-25 14:50 PDT, ben.fulton
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Garen 2006-10-08 20:54:10 PDT
TO REPRO:
1. Set window size to 947x878
2. Load http://msnbc.msn.com/id/15172758/?GT1=8618
---> Notice Inappropriate horizontal scrollbar
3. Scroll down
---> Notice that scrollbar moves with the page

Happens on Tiger & TOT.

Screenshot attached.
Comment 1 Geoffrey Garen 2006-10-08 20:54:38 PDT
Created attachment 10990 [details]
Screenshot
Comment 2 mitz 2006-10-08 23:01:27 PDT
Bug 8909 is the "vertical scrollbar" version of this bug.
Comment 3 mitz 2006-11-10 13:19:43 PST
*** Bug 11563 has been marked as a duplicate of this bug. ***
Comment 4 mitz 2007-02-26 05:05:17 PST
*** Bug 12893 has been marked as a duplicate of this bug. ***
Comment 5 mitz 2007-03-09 06:19:22 PST
*** Bug 13023 has been marked as a duplicate of this bug. ***
Comment 6 mitz 2007-05-31 01:17:32 PDT
*** Bug 13949 has been marked as a duplicate of this bug. ***
Comment 7 mitz 2007-07-23 22:31:13 PDT
*** Bug 13816 has been marked as a duplicate of this bug. ***
Comment 8 Alexey Proskuryakov 2007-08-11 22:51:11 PDT
Strangely, I can reproduce this with r24868 nightly, but not with shipping 10.4.10 Safari/WebKit. Same results on <http://www.w3.org/International/tests/>.
Comment 9 Elliott Sprehn 2007-08-11 23:23:44 PDT
(In reply to comment #8)
> Strangely, I can reproduce this with r24868 nightly, but not with shipping
> 10.4.10 Safari/WebKit. Same results on
> <http://www.w3.org/International/tests/>.
> 

I noted the same thing in 13949, thinking it was a regression. Several of the other duplicates also marked it that way.

I think "Happens on Tiger & TOT" means the OS and the browser, rather than Tiger's version of Webkit.
Comment 10 ben.fulton 2011-07-25 14:49:43 PDT
We are able to reproduce this problem in both Chrome 12 and Safari 5.1, on our listing pages. We are *not* able to repro using Safari 5.0.5 on OS X 10.6, which is surprising given the age of this particular bug.

To reproduce:

1. Run Chrome 12 or Safari 5.1.
2. Load http://www.redfin.com/CA/San-Francisco/2667-15th-Ave-94127/home/982757 (OR, any other listing page on our site).
3. Wait for the page to finish rendering.
4. Resize the window to exactly fit the content width. (There should be no
horizontal scrollbar.)
5. Reload the page. A horizontal scrollbar will appear as it is rendering, due
to the Facebook iframe hanging off outside of our content.
6. As the page is reloading, click and grab the vertical scrollbar and slowly
drag down.

Actual: When the page finishes rendering, a stale horizontal scrollbar will be
left behind. It may be partly painted over by other content. If you move it off
the page, it will be gone when you scroll the page back.

Expected: The horizontal scrollbar vanishes when the page finishes rendering.

Screenshot attached.
Comment 11 ben.fulton 2011-07-25 14:50:27 PDT
Created attachment 101915 [details]
Screenshot of the stale scrollbar on Redfin.
Comment 12 Robert Hogan 2013-06-04 11:20:04 PDT
This bug seems completely unreproducible now. I'm going to close it as there's nothing to work with here or in any of its duplicates.