Bug 128486 - Table elements with position:sticky have borders repainted incorrectly on scroll
Summary: Table elements with position:sticky have borders repainted incorrectly on scroll
Status: RESOLVED DUPLICATE of bug 94128
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zalan
URL:
Keywords: InRadar
Depends on:
Blocks: 128436
  Show dependency treegraph
 
Reported: 2014-02-08 20:35 PST by Brian Burg
Modified: 2018-08-23 01:41 PDT (History)
11 users (show)

See Also:


Attachments
testcase with position:sticky thead (1.90 KB, text/html)
2014-02-08 20:36 PST, Brian Burg
no flags Details
reduced test case (283 bytes, text/html)
2014-02-08 21:34 PST, zalan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Burg 2014-02-08 20:35:40 PST
When scrolling, the background of a position:sticky table row element is painted correctly as if it were position:fixed, but the row's borders follow the scrolled table contents.

In my testing, any of thead, th, td, tr with position:-webkit-sticky exhibit this bug. Other elements (divs, etc) draw borders correctly.
Comment 1 Brian Burg 2014-02-08 20:36:11 PST
Created attachment 223602 [details]
testcase with position:sticky thead
Comment 2 zalan 2014-02-08 21:34:41 PST
Created attachment 223607 [details]
reduced test case
Comment 3 Derk-Jan Hartman 2014-03-13 06:13:51 PDT
I suspect dupe of bug 94128
Comment 4 Derk-Jan Hartman 2017-03-29 08:14:32 PDT
3 years later, still a problem.

https://en.wikipedia.org/wiki/List_of_Space_Shuttle_missions?withCSS=MediaWiki:Gadget-StickyTableHeaders.css

The table headers here loose there borders whenever position sticky is used.
Comment 5 Brian Burg 2017-03-29 10:04:20 PDT

*** This bug has been marked as a duplicate of bug 94128 ***
Comment 6 Simon Fraser (smfr) 2017-03-29 11:13:14 PDT
Does this only happen on Retina displays?
Comment 7 Derk-Jan Hartman 2017-03-29 23:18:07 PDT
@simon I just tested. No it happens on both Retina and non-Retina.

Im also much less sure that this is an actual duplicate of 94128 btw. This seems much more likely to be a side effect of border collapse.
Comment 8 Radar WebKit Bug Importer 2017-04-07 19:18:02 PDT
<rdar://problem/31516367>
Comment 9 Yeshar 2018-08-21 13:33:44 PDT
This issue persists on Chrome. Not sure why it's listed as resolved. I'm guessing that people have come up with workarounds over the 4+ years this has been a bug... Any suggestions would be welcomed. :)
Comment 10 Derk-Jan Hartman 2018-08-23 01:41:29 PDT
I also don't think this is the same bug as the one it was closed as a dupe of. As far as I understand, this bug occurs due to border collapsing.