Bug 127414 - inspector-protocol/page/deny-X-FrameOption.html is very flaky
Summary: inspector-protocol/page/deny-X-FrameOption.html is very flaky
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 129331 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-22 00:17 PST by Alexey Proskuryakov
Modified: 2015-08-06 09:41 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2014-01-22 00:17:57 PST
inspector-protocol/page/deny-X-FrameOption.html fails very frequently on WebKit2 bots:

http://webkit-test-results.appspot.com/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=inspector-protocol%2Fpage%2Fdeny-X-FrameOption.html

The difference is:

------------------------
@@ -1,4 +1,5 @@
 CONSOLE MESSAGE: Refused to display 'deny-X-FrameOption.html' in a frame because it set 'X-Frame-Options' to 'deny'.
+CONSOLE MESSAGE: line 1: ReferenceError: Can't find variable: InspectorFrontendAPI
 
 deny-X-FrameOption.html:0:0
 ------------------------

I'm not sure where this error comes from, there is no "InspectorFrontendAPI" in this test. Presumably it's from Web Inspector code?

I could not reproduce this locally.
Comment 1 Radar WebKit Bug Importer 2014-01-22 00:18:08 PST
<rdar://problem/15878590>
Comment 2 Alexey Proskuryakov 2014-01-22 00:36:51 PST
This test does a suspicious document.write, landed a speculative fix to remove a race in <http://trac.webkit.org/r162509>. Let's see if this helps.
Comment 3 Alexey Proskuryakov 2014-01-22 09:29:25 PST
Alas, this didn't help.
Comment 4 Alexey Proskuryakov 2014-02-25 22:50:38 PST
*** Bug 129331 has been marked as a duplicate of this bug. ***
Comment 5 Alexey Proskuryakov 2014-02-25 22:50:55 PST
Marked as flaky in <http://trac.webkit.org/r164671>.
Comment 6 Brian Burg 2015-08-06 09:41:16 PDT
Rewritten in https://bugs.webkit.org/show_bug.cgi?id=147714, new file is

inspector-protocol/console/x-frame-options-message.html

So far it seems to be much more stable. Please file a new bug if problems creep up.