Bug 129331 - inspector-protocol/page/deny-X-FrameOption.html is very flaky
Summary: inspector-protocol/page/deny-X-FrameOption.html is very flaky
Status: RESOLVED DUPLICATE of bug 127414
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-02-25 13:30 PST by Alexey Proskuryakov
Modified: 2014-02-25 22:50 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2014-02-25 13:30:08 PST
inspector-protocol/page/deny-X-FrameOption.html is very flaky, frequently failing like this:

@@ -1,4 +1,5 @@
 CONSOLE MESSAGE: Refused to display 'deny-X-FrameOption.html' in a frame because it set 'X-Frame-Options' to 'deny'.
+CONSOLE MESSAGE: line 1: ReferenceError: Can't find variable: InspectorFrontendAPI
 
 deny-X-FrameOption.html:30:17
 

It's been like this on most bots for a long time - failing on first attempt, and passing on retry. But starting with <http://trac.webkit.org/changeset/164541>, some thing changed in that the test frequently fails on retry too.
Comment 1 Radar WebKit Bug Importer 2014-02-25 13:30:20 PST
<rdar://problem/16164383>
Comment 2 Alexey Proskuryakov 2014-02-25 13:33:04 PST
Marked as flaky in <http://trac.webkit.org/r164671>.
Comment 3 Alexey Proskuryakov 2014-02-25 22:50:38 PST

*** This bug has been marked as a duplicate of bug 127414 ***