Bug 126049 - Remove a significant source of memory allocations during CSS parsing
Summary: Remove a significant source of memory allocations during CSS parsing
Status: RESOLVED DUPLICATE of bug 140599
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: BlinkMergeCandidate
Depends on:
Blocks:
 
Reported: 2013-12-19 21:47 PST by Ryosuke Niwa
Modified: 2016-04-29 09:20 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2013-12-19 21:47:01 PST
Consider merging https://chromium.googlesource.com/chromium/blink/+/3d1744e53a3540be9bdb385deadec60469e6019c
or come up with a similar improvement

This is about +2% on Parser/css-parser-yui.html locally.

Previously, we were allocating and freeing small vector buffers (most commonly
24 or 72 byte allocations on 64-bit), only to immediately throw them away.

Note that uncheckedAppend has an ASSERT that will cleanly catch any future
problems with sizing.
Comment 1 Joseph Pecoraro 2016-04-28 17:11:20 PDT
Still worth taking? Seems like a pretty small change, but might be out of date now.
Comment 2 Chris Dumez 2016-04-29 09:20:35 PDT
I don't believe this is still needed after:
https://bugs.webkit.org/show_bug.cgi?id=140599

*** This bug has been marked as a duplicate of bug 140599 ***