Bug 125298 - 32bit buildfix after r160151
Summary: 32bit buildfix after r160151
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 125296 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-05 04:12 PST by Laszlo Vidacs
Modified: 2013-12-05 15:09 PST (History)
7 users (show)

See Also:


Attachments
Patch (1.58 KB, patch)
2013-12-05 04:57 PST, Laszlo Vidacs
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Laszlo Vidacs 2013-12-05 04:12:39 PST
32bit build fails with the following message:

Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp: In member function 'void StreamingClient::handleDataReceived(const char*, int)':
Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943:517: error: format '%ld' expects argument of type 'long int', but argument 8 has type 'unsigned int' [-Werror=format]

Buildbot: EFL Linux 32-bit Release (Build)
Comment 1 Laszlo Vidacs 2013-12-05 04:57:47 PST
Created attachment 218503 [details]
Patch
Comment 2 WebKit Commit Bot 2013-12-05 04:59:14 PST
Attachment 218503 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp', '--commit-queue']" exit_code: 1
ERROR: Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943:  Should be indented on a separate line, with the colon or comma first on that line.  [whitespace/indent] [4]
ERROR: Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943:  Comma should be at the beggining of the line in a member initialization list.  [whitespace/init] [4]
Total errors found: 2 in 2 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Laszlo Vidacs 2013-12-05 05:04:18 PST
This seems to be a false positive - no initialization list in this line.
Comment 4 Philippe Normand 2013-12-05 05:21:21 PST
Comment on attachment 218503 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=218503&action=review

> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943
> +    GST_LOG_OBJECT(src, "Have %lld bytes of data", priv->buffer ? static_cast<long long>(gst_buffer_get_size(priv->buffer.get())) : length);

Perhaps use %zd ?
Comment 5 Philippe Normand 2013-12-05 05:23:15 PST

*** This bug has been marked as a duplicate of bug 125296 ***
Comment 6 Csaba Osztrogonác 2013-12-05 14:39:59 PST
Comment on attachment 218503 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=218503&action=review

>> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943
>> +    GST_LOG_OBJECT(src, "Have %lld bytes of data", priv->buffer ? static_cast<long long>(gst_buffer_get_size(priv->buffer.get())) : length);
> 
> Perhaps use %zd ?

gst_buffer_get_size returns unsigned int (32bit), length is int (32bit).
An unsigned int can be extended properly to long long int (64bit) on x86.
So it is the proper fix, r=me to fix the build as soon as possible.
Comment 7 Csaba Osztrogonác 2013-12-05 14:40:20 PST
Reopen to let CQ land the fix.
Comment 8 Csaba Osztrogonác 2013-12-05 14:42:02 PST
*** Bug 125296 has been marked as a duplicate of this bug. ***
Comment 9 WebKit Commit Bot 2013-12-05 15:09:55 PST
Comment on attachment 218503 [details]
Patch

Clearing flags on attachment: 218503

Committed r160196: <http://trac.webkit.org/changeset/160196>
Comment 10 WebKit Commit Bot 2013-12-05 15:09:59 PST
All reviewed patches have been landed.  Closing bug.