Bug 125296 - [EFL] Buildfix after r160151
Summary: [EFL] Buildfix after r160151
Status: RESOLVED DUPLICATE of bug 125298
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit EFL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-05 02:52 PST by Krzysztof Czech
Modified: 2013-12-05 14:42 PST (History)
12 users (show)

See Also:


Attachments
patch (1.38 KB, patch)
2013-12-05 02:55 PST, Krzysztof Czech
eflews.bot: commit-queue-
Details | Formatted Diff | Diff
patch (1.40 KB, patch)
2013-12-05 04:57 PST, Krzysztof Czech
k.czech: commit-queue?
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Krzysztof Czech 2013-12-05 02:52:32 PST
/mnt/buildbot/efl-linux-slave-3/efl-linux-32-release/build/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943:517: error: format '%ld' expects argument of type 'long int', but argument 8 has type 'unsigned int' [-Werror=format]
Comment 1 Krzysztof Czech 2013-12-05 02:55:59 PST
Created attachment 218496 [details]
patch
Comment 2 WebKit Commit Bot 2013-12-05 02:58:10 PST
Attachment 218496 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp', '--commit-queue']" exit_code: 1
ERROR: Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943:  Should be indented on a separate line, with the colon or comma first on that line.  [whitespace/indent] [4]
ERROR: Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943:  Comma should be at the beggining of the line in a member initialization list.  [whitespace/init] [4]
Total errors found: 2 in 2 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Krzysztof Czech 2013-12-05 03:03:59 PST
Changing format specifier from %ld to %d
Comment 4 EFL EWS Bot 2013-12-05 03:11:24 PST
Comment on attachment 218496 [details]
patch

Attachment 218496 [details] did not pass efl-ews (efl):
Output: http://webkit-queues.appspot.com/results/39298350
Comment 5 EFL EWS Bot 2013-12-05 03:48:23 PST
Comment on attachment 218496 [details]
patch

Attachment 218496 [details] did not pass efl-wk2-ews (efl-wk2):
Output: http://webkit-queues.appspot.com/results/43618008
Comment 6 Nick Diego Yamane (diegoyam) 2013-12-05 04:25:03 PST
/mnt/eflews/webkit/WebKit/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp: In member function 'void StreamingClient::handleDataReceived(const char*, int)':
/mnt/eflews/webkit/WebKit/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943:483: error: format '%d' expects argument of type 'int', but argument 8 has type 'long unsigned int' [-Werror=format]

Looks like it should be %lu :)
Comment 7 Ryuan Choi 2013-12-05 04:34:36 PST
(In reply to comment #6)
> /mnt/eflews/webkit/WebKit/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp: In member function 'void StreamingClient::handleDataReceived(const char*, int)':
> /mnt/eflews/webkit/WebKit/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943:483: error: format '%d' expects argument of type 'int', but argument 8 has type 'long unsigned int' [-Werror=format]
> 
> Looks like it should be %lu :)

So, is static_cast<unsigned long>(length) only the solution ?
Comment 8 Krzysztof Czech 2013-12-05 04:53:46 PST
(In reply to comment #7)
> (In reply to comment #6)
> > /mnt/eflews/webkit/WebKit/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp: In member function 'void StreamingClient::handleDataReceived(const char*, int)':
> > /mnt/eflews/webkit/WebKit/Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943:483: error: format '%d' expects argument of type 'int', but argument 8 has type 'long unsigned int' [-Werror=format]
> > 
> > Looks like it should be %lu :)
> 
> So, is static_cast<unsigned long>(length) only the solution ?
What about signed values ?, maybe static_cast<long>(length)
Comment 9 Krzysztof Czech 2013-12-05 04:57:34 PST
Created attachment 218502 [details]
patch
Comment 10 WebKit Commit Bot 2013-12-05 04:58:45 PST
Attachment 218502 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp', '--commit-queue']" exit_code: 1
ERROR: Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943:  Should be indented on a separate line, with the colon or comma first on that line.  [whitespace/indent] [4]
ERROR: Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:943:  Comma should be at the beggining of the line in a member initialization list.  [whitespace/init] [4]
Total errors found: 2 in 2 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 11 Philippe Normand 2013-12-05 05:23:15 PST
*** Bug 125298 has been marked as a duplicate of this bug. ***
Comment 12 Laszlo Vidacs 2013-12-05 05:40:45 PST
A possible solution is submitted to https://bugs.webkit.org/show_bug.cgi?id=125298
Unsigned int does not fit in long int, so the common type for both values could be long long int.

Could you take a look at that patch?
Comment 13 Csaba Osztrogonác 2013-12-05 14:42:02 PST
Mark this one as duplicate, because the other bug contains the proper fix.

*** This bug has been marked as a duplicate of bug 125298 ***