Bug 122811 - Add support for the object-position CSS property
Summary: Add support for the object-position CSS property
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: BlinkMergeCandidate, InRadar, WebExposed
Depends on: 155065
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 21:19 PDT by Ryosuke Niwa
Modified: 2016-03-07 09:08 PST (History)
14 users (show)

See Also:


Attachments
Patch (31.29 KB, patch)
2016-03-05 15:31 PST, Simon Fraser (smfr)
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2013-10-14 21:19:48 PDT
Consider merging https://chromium.googlesource.com/chromium/blink/+/873dbff72d843c6e6828e48087a76d5fbd30d4a3
if we want to support object-position CSS property

This is hidden behind an "experimental" runtime flag named
"ObjectFitPosition", together with object-fit.

This is an implementation of object-position as described in
http://www.w3.org/TR/2012/CR-css3-images-20120417/#object-position

Object-position is used to offset replaced content within its content
box. Painting is always clipped against the content box, regardless of
the "overflow" property. This property is useful together with
object-fit (to achieve a difference between content box size and
replaced content size, so that specifying alignment is interesting),
but can also be used on its own.
Comment 3 Radar WebKit Bug Importer 2014-01-16 10:16:55 PST
<rdar://problem/15836338>
Comment 4 yisibl 2015-07-08 20:09:22 PDT
Please fix this problem as soon as possible.

Chrome 31 and Firefox 36 has supported. https://developer.mozilla.org/zh-CN/docs/Web/CSS/object-position#Browser_compatibility
Comment 5 codemaker 2015-12-06 15:37:18 PST
Also hoping for implementation.

I've filed a bug with Apple Bug reporter as occurring in Safari - their issue/filing number 23777385. Awaiting pickup.

Happy to help if anything can be done currently.
Comment 6 codemaker 2015-12-14 05:18:19 PST
Ok, my Apple Bug Reporter issue #23777385 response is that the issue is a duplicate of an exising open issue #15836338. Mine has therefore been closed.

Apple Bug Reporter doesn't disclose any further information on the open issue #15836338 to me as I didn't file it, only that it exists and is open.

Optimistically it's been +1ed and progress on resolution is well on its way. In reality, who knows unless you work there fixing bugs. Fingers crossed then I suppose!

I would welcome hearing from anyone who knows more on this issue...
Comment 7 yisibl 2015-12-14 05:28:39 PST
(In reply to comment #6)
> Ok, my Apple Bug Reporter issue #23777385 response is that the issue is a
> duplicate of an exising open issue #15836338. Mine has therefore been closed.
> 
> Apple Bug Reporter doesn't disclose any further information on the open
> issue #15836338 to me as I didn't file it, only that it exists and is open.
> 
> Optimistically it's been +1ed and progress on resolution is well on its way.
> In reality, who knows unless you work there fixing bugs. Fingers crossed
> then I suppose!
> 
> I would welcome hearing from anyone who knows more on this issue...

I think Simon Fraser(simon.fraser@apple.com) can help us fix this bug.
Comment 8 Simon Fraser (smfr) 2016-03-05 15:31:15 PST
Created attachment 273103 [details]
Patch
Comment 9 Simon Fraser (smfr) 2016-03-05 16:01:39 PST
https://trac.webkit.org/r197618
Comment 10 Alexey Proskuryakov 2016-03-05 17:04:09 PST
Could you please correct iOS results? There are three new failures.

https://build.webkit.org/results/Apple%20iOS%209%20Simulator%20Release%20WK2%20(Tests)/r197618%20(3676)/results.html
Comment 11 Ryan Haddad 2016-03-07 09:08:25 PST
(In reply to comment #10)
> Could you please correct iOS results? There are three new failures.
> 
> https://build.webkit.org/results/
> Apple%20iOS%209%20Simulator%20Release%20WK2%20(Tests)/r197618%20(3676)/
> results.html

Filed https://bugs.webkit.org/show_bug.cgi?id=155116 to track.