Bug 121584 - MediaStream API: update NavigatorUserMediaError object to match spec
Summary: MediaStream API: update NavigatorUserMediaError object to match spec
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Eric Carlson
URL:
Keywords: InRadar
: 121404 (view as bug list)
Depends on:
Blocks: 124288
  Show dependency treegraph
 
Reported: 2013-09-18 20:00 PDT by Eric Carlson
Modified: 2013-11-14 07:39 PST (History)
11 users (show)

See Also:


Attachments
Proposed patch (24.54 KB, patch)
2013-09-18 21:44 PDT, Eric Carlson
no flags Details | Formatted Diff | Diff
Updated patch (24.54 KB, patch)
2013-09-19 07:02 PDT, Eric Carlson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Carlson 2013-09-18 20:00:28 PDT
NavigatorUserMediaError should inherit from DOMError, should not have a "message" attribute.
Comment 1 Eric Carlson 2013-09-18 20:00:45 PDT
<rdar://problem/15022765>
Comment 2 Eric Carlson 2013-09-18 21:44:09 PDT
Created attachment 212034 [details]
Proposed patch
Comment 3 WebKit Commit Bot 2013-09-18 21:47:04 PDT
Attachment 212034 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/fast/mediastream/getusermedia-expected.txt', u'LayoutTests/fast/mediastream/getusermedia.html', u'Source/WebCore/CMakeLists.txt', u'Source/WebCore/ChangeLog', u'Source/WebCore/GNUmakefile.list.am', u'Source/WebCore/Modules/mediastream/NavigatorUserMediaError.cpp', u'Source/WebCore/Modules/mediastream/NavigatorUserMediaError.h', u'Source/WebCore/Modules/mediastream/NavigatorUserMediaError.idl', u'Source/WebCore/Modules/mediastream/UserMediaRequest.cpp', u'Source/WebCore/Modules/mediastream/UserMediaRequest.h', u'Source/WebCore/WebCore.xcodeproj/project.pbxproj', u'Source/WebCore/dom/DOMError.h', u'Source/WebCore/platform/mediastream/MediaStreamSourcesQueryClient.h']" exit_code: 1
Source/WebCore/Modules/mediastream/NavigatorUserMediaError.cpp:30:  You should add a blank line after implementation file's own header.  [build/include_order] [4]
Total errors found: 1 in 14 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Eric Carlson 2013-09-18 21:52:24 PDT
(In reply to comment #3)
> Attachment 212034 [details] did not pass style-queue:
> 
> Source/WebCore/Modules/mediastream/NavigatorUserMediaError.cpp:30:  You should add a blank line after implementation file's own header.  [build/include_order] [4]

Oh the horror!
Comment 5 Eric Carlson 2013-09-19 07:02:51 PDT
Created attachment 212064 [details]
Updated patch
Comment 6 Dean Jackson 2013-09-19 10:37:31 PDT
Comment on attachment 212064 [details]
Updated patch

View in context: https://bugs.webkit.org/attachment.cgi?id=212064&action=review

> Source/WebCore/Modules/mediastream/UserMediaRequest.h:68
> +    virtual PassRefPtr<MediaConstraints> videoConstraints() const  OVERRIDE;

Nit: two spaces before OVERRIDE

> Source/WebCore/Modules/mediastream/UserMediaRequest.h:69
> +    virtual void didCompleteQuery(const MediaStreamSourceVector& audioSources, const MediaStreamSourceVector& videoSources)  OVERRIDE;

Here too.
Comment 7 Eric Carlson 2013-09-19 12:06:20 PDT
Committed r156108: https://trac.webkit.org/r156108
Comment 8 Eric Carlson 2013-09-26 17:10:59 PDT
*** Bug 121404 has been marked as a duplicate of this bug. ***