Bug 121050 - Assertion can fail when removing display: none SVG elements
Summary: Assertion can fail when removing display: none SVG elements
Status: RESOLVED DUPLICATE of bug 140602
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2013-09-09 14:45 PDT by Vicki Pfau
Modified: 2015-04-22 14:43 PDT (History)
2 users (show)

See Also:


Attachments
Repro (362 bytes, text/html)
2013-09-09 14:45 PDT, Vicki Pfau
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vicki Pfau 2013-09-09 14:45:04 PDT
Created attachment 211088 [details]
Repro

When there are two SVG elements in a display: none container, and the second SVG element refers to the first SVG element with a use element, an assertion may be thrown if children of the original SVG element are removed from the DOM. A simple repro is attached.

The failing assertion is (*it)->shadowTreeElement()->correspondingElement() in SVGElementInstance::invalidateAllInstancesOfElement(WebCore::SVGElement *).

<rdar://problem/14887645>
Comment 1 Said Abou-Hallawa 2015-04-22 14:43:28 PDT
The SVGElementInstance was removed completely from the source tree: https://bugs.webkit.org/show_bug.cgi?id=140602. And I confirmed that the repro test case opens in WebKit with no problem.

*** This bug has been marked as a duplicate of bug 140602 ***