Bug 120766 - Make build.webkit.org report the number of failing run-fast-jsc tests
Summary: Make build.webkit.org report the number of failing run-fast-jsc tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Csaba Osztrogonác
URL:
Keywords:
Depends on:
Blocks: 120696
  Show dependency treegraph
 
Reported: 2013-09-05 04:34 PDT by Csaba Osztrogonác
Modified: 2013-09-05 12:21 PDT (History)
7 users (show)

See Also:


Attachments
unit test for run-javascriptcore-test step (3.40 KB, patch)
2013-09-05 05:21 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff
Patch (6.32 KB, patch)
2013-09-05 07:14 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2013-09-05 04:34:47 PDT
After https://trac.webkit.org/changeset/155092 master.cfg's
result parser of run-javascript-core-tests should be adjusted.

Now it reports only the old mozilla tests failures. It should 
report the number of failing run-fast-jsc tests too.
Comment 1 Csaba Osztrogonác 2013-09-05 05:21:38 PDT
Created attachment 210603 [details]
unit test for run-javascriptcore-test step

This unit test contains the old and the new output. But it seems that the number if failing fast/js tests is still missing.
Comment 2 Csaba Osztrogonác 2013-09-05 07:14:12 PDT
Created attachment 210614 [details]
Patch
Comment 3 WebKit Commit Bot 2013-09-05 07:16:40 PDT
Attachment 210614 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Tools/BuildSlaveSupport/build.webkit.org-config/master.cfg', u'Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py', u'Tools/ChangeLog']" exit_code: 1
Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:107:  [RunJavaScriptCoreTestsTest.assertResults] Undefined variable 'RunJavaScriptCoreTests'  [pylint/E0602] [5]
Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:116:  [RunJavaScriptCoreTestsTest.test_no_regressions_old_output] Undefined variable 'SUCCESS'  [pylint/E0602] [5]
Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:122:  [RunJavaScriptCoreTestsTest.test_mozilla_failure_old_output] Undefined variable 'FAILURE'  [pylint/E0602] [5]
Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:127:  [RunJavaScriptCoreTestsTest.test_mozilla_failure_new_output] Undefined variable 'FAILURE'  [pylint/E0602] [5]
Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:137:  [RunJavaScriptCoreTestsTest.test_fast_js_failure_new_output] Undefined variable 'FAILURE'  [pylint/E0602] [5]
Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:147:  [RunJavaScriptCoreTestsTest.test_fast_js_crash_new_output] Undefined variable 'FAILURE'  [pylint/E0602] [5]
Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:157:  [RunJavaScriptCoreTestsTest.test_mozilla_and_fast_js_failure_new_output] Undefined variable 'FAILURE'  [pylint/E0602] [5]
Total errors found: 7 in 3 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Csaba Osztrogonác 2013-09-05 07:19:02 PDT
(In reply to comment #3)
> Attachment 210614 [details] did not pass style-queue:
> 
> Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Tools/BuildSlaveSupport/build.webkit.org-config/master.cfg', u'Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py', u'Tools/ChangeLog']" exit_code: 1
> Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:107:  [RunJavaScriptCoreTestsTest.assertResults] Undefined variable 'RunJavaScriptCoreTests'  [pylint/E0602] [5]
> Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:116:  [RunJavaScriptCoreTestsTest.test_no_regressions_old_output] Undefined variable 'SUCCESS'  [pylint/E0602] [5]
> Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:122:  [RunJavaScriptCoreTestsTest.test_mozilla_failure_old_output] Undefined variable 'FAILURE'  [pylint/E0602] [5]
> Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:127:  [RunJavaScriptCoreTestsTest.test_mozilla_failure_new_output] Undefined variable 'FAILURE'  [pylint/E0602] [5]
> Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:137:  [RunJavaScriptCoreTestsTest.test_fast_js_failure_new_output] Undefined variable 'FAILURE'  [pylint/E0602] [5]
> Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:147:  [RunJavaScriptCoreTestsTest.test_fast_js_crash_new_output] Undefined variable 'FAILURE'  [pylint/E0602] [5]
> Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:157:  [RunJavaScriptCoreTestsTest.test_mozilla_and_fast_js_failure_new_output] Undefined variable 'FAILURE'  [pylint/E0602] [5]
> Total errors found: 7 in 3 files
> 
> 
> If any of these errors are false positives, please file a bug against check-webkit-style.

False positive warnings, these variables come from the master.cfg,
which is loaded dinamycally.
Comment 5 Csaba Osztrogonác 2013-09-05 09:41:01 PDT
Comment on attachment 210614 [details]
Patch

Clearing flags on attachment: 210614

Committed r155124: <http://trac.webkit.org/changeset/155124>
Comment 6 Csaba Osztrogonác 2013-09-05 09:41:06 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Csaba Osztrogonác 2013-09-05 09:45:57 PDT
Reopen, because it seems automatic master restart 
on build.webkit.org doesn't work again.

@rniwa, @lforscler or @wms: Could you restart it please? Thanks.
Comment 8 Lucas Forschler 2013-09-05 10:20:48 PDT
restarted at 10:20am, PST
Comment 9 Csaba Osztrogonác 2013-09-05 12:21:43 PDT
Thanks.