Bug 120585 - [Qt4] Crash on tools.wmflabs.org
Summary: [Qt4] Crash on tools.wmflabs.org
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: QtWebkit23
  Show dependency treegraph
 
Reported: 2013-09-01 13:31 PDT by jingdow
Modified: 2013-12-20 12:14 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jingdow 2013-09-01 13:31:46 PDT
Qtwebkit based browsers with WebGL enabled crash on tools.wmflabs.org pages.

Page: http://tools.wmflabs.org/geohack/geohack.php?pagename=Gates_of_Belgrade&params=44_47_3_N_20_30_44_E_&title=Eastern+Gate+of+Belgrade

qtwebkit version: 2.3.2 (latest git from http://gitorious.org/webkit/qtwebkit-23)

Browsers tested: QupZilla & QtTestBrowser

Backtraces:
QupZilla: http://pastebin.com/gVZGmAnM
QtTestBrowser: http://pastebin.com/vuUmxgae

Note: In QtTestBrowser you must enable WebGL in order to reproduce the crash.
Comment 1 Arunprasad Rajkumar 2013-09-01 21:41:23 PDT
(In reply to comment #0)
> Qtwebkit based browsers with WebGL enabled crash on tools.wmflabs.org pages.
> 
> Page: http://tools.wmflabs.org/geohack/geohack.php?pagename=Gates_of_Belgrade&params=44_47_3_N_20_30_44_E_&title=Eastern+Gate+of+Belgrade
> 
> qtwebkit version: 2.3.2 (latest git from http://gitorious.org/webkit/qtwebkit-23)
> 
> Browsers tested: QupZilla & QtTestBrowser
> 
> Backtraces:
> QupZilla: http://pastebin.com/gVZGmAnM
> QtTestBrowser: http://pastebin.com/vuUmxgae
> 
> Note: In QtTestBrowser you must enable WebGL in order to reproduce the crash.

What is your Graphics Driver? Incase your's is not MESA, try with MESA & share the results?
Comment 2 jingdow 2013-09-01 22:28:57 PDT
It could be the mesa's fault! I use mesa git tree (r600g), and recently they've enabled 'sb' shader optimization backend as default. I've tried several other pages which require WebGL (among them a simple http://get.webgl.org/), and I get a crash every time.

Will it help if I build mesa with debugging symbols?
Comment 3 Arunprasad Rajkumar 2013-09-01 22:30:33 PDT
(In reply to comment #2)
> It could be the mesa's fault! I use mesa git tree (r600g), and recently they've enabled 'sb' shader optimization backend as default. I've tried several other pages which require WebGL (among them a simple http://get.webgl.org/), and I get a crash every time.
> 
> Will it help if I build mesa with debugging symbols?

So from your comment you are using non stable mesa driver. Could you install stable mesa & hav a try?
Comment 4 jingdow 2013-09-01 22:35:33 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > It could be the mesa's fault! I use mesa git tree (r600g), and recently they've enabled 'sb' shader optimization backend as default. I've tried several other pages which require WebGL (among them a simple http://get.webgl.org/), and I get a crash every time.
> > 
> > Will it help if I build mesa with debugging symbols?
> 
> So from your comment you are using non stable mesa driver. Could you install stable mesa & hav a try?

Yes, no problem.

Just to note, it's not the new shader optimization backend's fault, because I get the same crash with R600_DEBUG=nosb.

Will report immediately with stable driver from Arch Linux's repo.
Comment 5 jingdow 2013-09-01 22:41:31 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > It could be the mesa's fault! I use mesa git tree (r600g), and recently they've enabled 'sb' shader optimization backend as default. I've tried several other pages which require WebGL (among them a simple http://get.webgl.org/), and I get a crash every time.
> > 
> > Will it help if I build mesa with debugging symbols?
> 
> So from your comment you are using non stable mesa driver. Could you install stable mesa & hav a try?

Tried mesa and ati-dri 9.2.0 stable. Getting the same crash.
Comment 6 Arunprasad Rajkumar 2013-09-01 22:51:15 PDT
(In reply to comment #5)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > It could be the mesa's fault! I use mesa git tree (r600g), and recently they've enabled 'sb' shader optimization backend as default. I've tried several other pages which require WebGL (among them a simple http://get.webgl.org/), and I get a crash every time.
> > > 
> > > Will it help if I build mesa with debugging symbols?
> > 
> > So from your comment you are using non stable mesa driver. Could you install stable mesa & hav a try?
> 
> Tried mesa and ati-dri 9.2.0 stable. Getting the same crash.

ahh!. I also had issues with ati-dri. pls disable the ATI DRI  using ATI catalyst control center & try with plain mesa.

You can confirm with "gfxinfo" tool.
Comment 7 jingdow 2013-09-02 01:20:58 PDT
No no, ati-dri is the Arch Linux's package name for mesa3d ati drivers. I don't use catalyst drivers (I actually never had).
Comment 8 Arunprasad Rajkumar 2013-09-02 04:32:04 PDT
(In reply to comment #7)
> No no, ati-dri is the Arch Linux's package name for mesa3d ati drivers. I don't use catalyst drivers (I actually never had).

can you publish your "glxinfo" output?
Comment 9 jingdow 2013-09-02 05:08:26 PDT
% glxinfo G OpenGL    
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV635
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.0
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 9.2.0
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

Complete report: http://pastebin.com/6Tis03mX
Comment 10 Arunprasad Rajkumar 2013-09-02 05:21:58 PDT
(In reply to comment #9)
> % glxinfo G OpenGL    
> OpenGL vendor string: X.Org
> OpenGL renderer string: Gallium 0.4 on AMD RV635
> OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.0
> OpenGL core profile shading language version string: 1.40
> OpenGL core profile context flags: (none)
> OpenGL core profile extensions:
> OpenGL version string: 3.0 Mesa 9.2.0
> OpenGL shading language version string: 1.30
> OpenGL context flags: (none)
> 
> Complete report: http://pastebin.com/6Tis03mX

Can you try with export LIBGL_ALWAYS_SOFTWARE=1 ? (force s/w rasterizer)

export LIBGL_ALWAYS_SOFTWARE=1;
QtTestBrowser http://get.webgl.org;

Just to ensure it is a driver issue.
Comment 11 jingdow 2013-09-02 05:36:00 PDT
(In reply to comment #10)
> 
> Can you try with export LIBGL_ALWAYS_SOFTWARE=1 ? (force s/w rasterizer)
> 
> export LIBGL_ALWAYS_SOFTWARE=1;
> QtTestBrowser http://get.webgl.org;
> 
> Just to ensure it is a driver issue.

It crashes again.
Comment 12 Allan Sandfeld Jensen 2013-09-10 02:09:08 PDT
For the record. I can not make it crash on the given site.

Would it be possible to build without production_build set, so we can get a better backtrace?
Comment 13 jingdow 2013-12-20 12:14:12 PST
Just to report, I don't have this crash anymore. Don't know how or why.