Bug 119562 - WebGL on AppleWin port needs GraphicsContext3D
Summary: WebGL on AppleWin port needs GraphicsContext3D
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 57421 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-07 16:08 PDT by Alex Christensen
Modified: 2014-01-09 20:51 PST (History)
4 users (show)

See Also:


Attachments
Patch (10.83 KB, patch)
2013-08-08 00:08 PDT, Alex Christensen
bfulgham: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Christensen 2013-08-07 16:08:51 PDT
This patch represents a step towards getting WebGL working on the AppleWin port.  I've moved GLContext and GraphicsContext3DPrivate in the Visual Studio filters and enabled them on Windows, made GraphicsContext3DWin almost identical to GraphicsContext3DCairo, and made a PlatformCALayer.  This code compiles and runs without crashing, but it still doesn't draw to the screen.  It's a step in the right direction, though.
Comment 1 Alex Christensen 2013-08-08 00:08:35 PDT
Created attachment 208314 [details]
Patch
Comment 2 Brent Fulgham 2013-08-08 12:13:19 PDT
Comment on attachment 208314 [details]
Patch

r=me
Comment 3 Alex Christensen 2013-08-08 13:18:36 PDT
r153843
Comment 4 Brent Fulgham 2014-01-09 20:51:59 PST
*** Bug 57421 has been marked as a duplicate of this bug. ***