Bug 11907 - RenderSVGContainer does not mark itself for repaint after setting viewBox, slice or align
Summary: RenderSVGContainer does not mark itself for repaint after setting viewBox, sl...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P4 Blocker
Assignee: Rob Buis
URL:
Keywords:
: 12181 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-12-21 05:03 PST by Eric Seidel (no email)
Modified: 2010-01-13 18:46 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2006-12-21 05:03:53 PST
RenderSVGContainer does not mark itself for repaint after setting viewBox, slice or align

It should invalidate itself when these change.
Comment 1 Nikolas Zimmermann 2007-01-09 14:53:44 PST
Rob fixed the viewBox case. Others are trivial to fix, too.
Comment 2 Eric Seidel (no email) 2007-06-12 11:06:24 PDT
*** Bug 12181 has been marked as a duplicate of this bug. ***
Comment 3 Nikolas Zimmermann 2010-01-13 18:46:34 PST
This is fixed nowadays. Changing ie. slice is only possible through JS, either by setting preserveAspectRatio attribute or by using SVG DOM directly, both cases cause a svgAttributeChanged(preserveAspectRatioAttr) call to be fired on the individual SVG*Element classes, causing them to call setNeedsLayout(true) on their renderer. It also works for resources and instances of elements, so it's really fixed today :-) Closing bug.