Bug 11883 - SVG Text has updating/repainting issues
Summary: SVG Text has updating/repainting issues
Status: RESOLVED DUPLICATE of bug 11984
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-19 14:42 PST by Nikolas Zimmermann
Modified: 2007-01-08 16:40 PST (History)
2 users (show)

See Also:


Attachments
Testcase (1.41 KB, image/svg+xml)
2006-12-19 14:43 PST, Nikolas Zimmermann
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolas Zimmermann 2006-12-19 14:42:33 PST
When animation SVG text from JavaScript, it shows repainting issues. Attaching testcase for Oliver.
Comment 1 Nikolas Zimmermann 2006-12-19 14:43:30 PST
Created attachment 11922 [details]
Testcase

Setting the viewBox="" attribute on the <svg> also results in funny drawing bugs. Play around with it :-)
Comment 2 Eric Seidel (no email) 2006-12-21 05:06:07 PST
The viewBox bugs are known.  I just filed bug 11907 to track those.

I assume the text just isn't invalidating here after changing the transform.  It looks like SVGTextElement::updateLocalTransform is supposed to do just that though.  So possibly the layout is not causing the proper repaint to occur.
Comment 3 Eric Seidel (no email) 2007-01-08 16:40:48 PST
Fixed by bug 11984.

*** This bug has been marked as a duplicate of 11984 ***