Bug 118813 - assertion in WebCore::RenderMathMLBlock::preferredLogicalHeight() const
Summary: assertion in WebCore::RenderMathMLBlock::preferredLogicalHeight() const
Status: RESOLVED DUPLICATE of bug 118298
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-17 14:36 PDT by Stephanie Lewis
Modified: 2013-07-17 14:41 PDT (History)
5 users (show)

See Also:


Attachments
crash log (46.82 KB, text/plain)
2013-07-17 14:36 PDT, Stephanie Lewis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephanie Lewis 2013-07-17 14:36:23 PDT
Created attachment 206914 [details]
crash log

Failing on ML and Lion, WK1 and WK2.  Started after http://trac.webkit.org/changeset/152777 turned the tests into ref tests.

ASSERTION FAILED: !isPreferredLogicalHeightDirty()
/Volumes/Data/slave/lion-debug/build/Source/WebCore/rendering/mathml/RenderMathMLBlock.h(74) : WebCore::LayoutUnit WebCore::RenderMathMLBlock::preferredLogicalHeight() const
1   0x104b350a0 WTFCrash
2   0x1074489ea WebCore::RenderMathMLBlock::preferredLogicalHeight() const
3   0x107447ce7 WebCore::RenderMathMLBlock::preferredLogicalHeightAfterSizing(WebCore::RenderObject*)
4   0x10744dc76 WebCore::RenderMathMLRow::computePreferredLogicalWidths()
5   0x107334769 WebCore::RenderBox::maxPreferredLogicalWidth() const
6   0x107447b6f WebCore::RenderMathMLBlock::computeChildrenPreferredLogicalHeights()
7   0x10744dbe9 WebCore::RenderMathMLRow::computePreferredLogicalWidths()
8   0x1073346e9 WebCore::RenderBox::minPreferredLogicalWidth() const
9   0x1072d1b51 WebCore::RenderBlock::computeInlinePreferredLogicalWidths(WebCore::LayoutUnit&, WebCore::LayoutUnit&)
10  0x1072d1280 WebCore::RenderBlock::computeIntrinsicLogicalWidths(WebCore::LayoutUnit&, WebCore::LayoutUnit&) const
11  0x1072d3a33 WebCore::RenderBlock::computePreferredLogicalWidths()
12  0x107334769 WebCore::RenderBox::maxPreferredLogicalWidth() const
13  0x107345848 WebCore::RenderBox::computePositionedLogicalWidthUsing(WebCore::Length, WebCore::RenderBoxModelObject const*, WebCore::TextDirection, WebCore::LayoutUnit, WebCore::LayoutUnit, WebCore::Length, WebCore::Length, WebCore::Length, WebCore::Length, WebCore::RenderBox::LogicalExtentComputedValues&) const
14  0x10733ccc9 WebCore::RenderBox::computePositionedLogicalWidth(WebCore::RenderBox::LogicalExtentComputedValues&, WebCore::RenderRegion*) const
15  0x10733bce0 WebCore::RenderBox::computeLogicalWidthInRegion(WebCore::RenderBox::LogicalExtentComputedValues&, WebCore::RenderRegion*) const
16  0x10733bb37 WebCore::RenderBox::updateLogicalWidth()
17  0x1072b32cf WebCore::RenderBlock::updateLogicalWidthAndColumnWidth()
18  0x1072b375b WebCore::RenderBlock::layoutBlock(bool, WebCore::LayoutUnit)
19  0x1072b2e3d WebCore::RenderBlock::layout()
20  0x10666ae36 WebCore::RenderObject::layoutIfNeeded()
21  0x1072b6f73 WebCore::RenderBlock::layoutPositionedObjects(bool, bool)
22  0x1072b3f43 WebCore::RenderBlock::layoutBlock(bool, WebCore::LayoutUnit)
23  0x1072b2e3d WebCore::RenderBlock::layout()
24  0x10757399d WebCore::RenderView::layoutContent(WebCore::LayoutState const&)
25  0x1075747e3 WebCore::RenderView::layout()
26  0x106703b29 WebCore::FrameView::layout(bool)
27  0x10646639f WebCore::Document::implicitClose()
28  0x1066da39b WebCore::FrameLoader::checkCallImplicitClose()
29  0x1066da016 WebCore::FrameLoader::checkCompleted()
30  0x1066d8b58 WebCore::FrameLoader::finishedParsing()
31  0x10647114b WebCore::Document::finishedParsing()
Comment 1 Stephanie Lewis 2013-07-17 14:36:59 PDT
Failing Tests:


+mathml/presentation/bug95015.html	crash log sample
+mathml/presentation/scripts-width.html	crash log sample
+mathml/presentation/scripts-underover.html	crash log sample
+mathml/presentation/bug97990.html	crash log sample
+mathml/presentation/scripts-height.html	crash log sample
+mathml/presentation/scripts-mrow.html	crash log sample
+mathml/presentation/scripts-subsup.html	crash log sample
Comment 2 Frédéric Wang (:fredw) 2013-07-17 14:40:43 PDT
This is probably a duplicate of bug 118298 and is likely to be fixed by bug 118601, comment 6.
Comment 3 chris fleizach 2013-07-17 14:41:02 PDT

*** This bug has been marked as a duplicate of bug 118298 ***