Bug 115585 - [QNX][ARM] REGRESSION(r133953): Failure in Octane/Splay
Summary: [QNX][ARM] REGRESSION(r133953): Failure in Octane/Splay
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 108645
  Show dependency treegraph
 
Reported: 2013-05-04 02:34 PDT by Cosmin Truta
Modified: 2017-10-18 01:49 PDT (History)
4 users (show)

See Also:


Attachments
Patch (2.35 KB, patch)
2013-05-04 02:37 PDT, Cosmin Truta
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Cosmin Truta 2013-05-04 02:34:06 PDT
On QNX ARM, 64-bit float arguments must be aligned. The call to operationArrayPushDouble leads to unpredictable results, because the J_DFGOperation_EDA operation doesn't currently take this into consideration.
A patch will follow.
Comment 1 Cosmin Truta 2013-05-04 02:37:32 PDT
Created attachment 200527 [details]
Patch
Comment 2 Cosmin Truta 2013-05-06 22:40:48 PDT
Comment on attachment 200527 [details]
Patch

I am clearing the r?/cq? flags at this moment, as I realized that alignment of FPRReg by the means of EABI_32BIT_DUMMY_ARG might require different handling between QNX and Linux.
Moreover, I realized that V_DFGOperation_EOZD (calling operationPutDoubleByValBeyondArrayBoundsStrict and operationPutDoubleByValBeyondArrayBoundsNonStrict) needs to be fixed in the same way as J_DFGOperation_EDA.
Comment 3 Zan Dobersek 2017-10-18 01:49:26 PDT
This is too old to be actionable.