Bug 114766 - Webkit r127852 (last build for Snow Leopard) crashes after Safari 5.19 update on OSX 10.6.8
Summary: Webkit r127852 (last build for Snow Leopard) crashes after Safari 5.19 update...
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Blocker
Assignee: Nobody
URL: all
Keywords:
: 114863 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-17 14:15 PDT by Jurek R.
Modified: 2013-04-20 20:43 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jurek R. 2013-04-17 14:15:02 PDT
The last webkit build for Snow Leopard r127852 does crash on start, after I installed the official Safari 5.19 update from Apple for Snow Leopard OSX 10.6.8.

So it's not possible to use Webkit anymore. Can you make a new special build for Snow Leopard please? Thanks.
Comment 1 Jurek R. 2013-04-17 14:19:11 PDT
This is the problem description from crash reporter:


Dyld Error Message:
  Symbol not found: _WKContextCopyPlugInInfoForBundleIdentifier
  Referenced from: /System/Library/PrivateFrameworks/Safari.framework/Versions/A/Safari
  Expected in: /Applications/Netz/WebKit.app/Contents/Frameworks/10.6/WebKit2.framework/Versions/A/WebKit2
 in /System/Library/PrivateFrameworks/Safari.framework/Versions/A/Safari
Comment 2 Mark Rowe (bdash) 2013-04-17 14:27:11 PDT
Snow Leopard has not been supported in the WebKit nightlies for over six months. There's nothing we can do to retroactively make old builds work with newer versions of Safari.
Comment 3 Jurek R. 2013-04-18 08:29:06 PDT
That's really silly, because to be honest, Safari 5.19 is really a scamped result for all Snow Leopard users:

The vertical scrolling is laggy as hell (why that??), the window resizing often only works with 5 frames / second?!? (I have a quadcore Mac).

Safari 5.17 was better in that, even better was Safari 5.05 (using webkit1 engine).

Using Webkit r127852 was the only way to utilize Webkit1 engine instead of the laggy Webkit2 engine. Now this way is gone. 

What should I do now? Redeem the patch? But as web designer I has to go with every step Apple makes, because the clients will do so, too.

Would be the GUI performance better with Mountain Lion? I doubt that... 

I think there is something really going wrong at Apple.
Seriously, isn't there any software quality control at Apple anymore?
Comment 4 Alexey Proskuryakov 2013-04-18 10:54:39 PDT
> The vertical scrolling is laggy as hell (why that??), the window resizing often only works with 5 frames / second?!? (I have a quadcore Mac).

> Safari 5.17 was better in that, even better was Safari 5.05 (using webkit1 engine).

If you are observing regressions like that, please file reports about them via <http://bugreport.apple.com>. However, I'm personally not seeing that on a Mac mini that has Snow Leopard.
Comment 5 Alexey Proskuryakov 2013-04-19 04:50:17 PDT
*** Bug 114863 has been marked as a duplicate of this bug. ***
Comment 6 bb553 2013-04-19 16:07:50 PDT
As Computerworld and InsanelyMac recently pointed out, Apple is supporting OS X 10.6.8 for it's Intel CPU users - As 45% of the OS X Intel users are running OS X 10.6.8 for needed software compatibility (including for any program or utility that requires the QuickTransit technology "Rosetta" dynamic binary translator to run *), this shouldn't be surprising. Apple has also resumed selling Snow Leopard [ http://store.apple.com/us/product/MC573Z/A/mac-os-x-106-snow-leopard ].

Note: Raymond Chen of Microsoft has pointed for many years, that "backwards software compatibility' on any computing Platform/OS is not a game", and also pointed out that was one of the primary reasons that some versions of Windows ended up being the predominant operating systems, even if other Platforms/operating systems were more advanced in some areas.


* If a standalone version of the "Rosetta" dynamic binary translator compatible with OS X 10.7.x and OS x 10.8.x, that users could purchase and install is ever released, this situation might change...
Comment 7 Mark Rowe (bdash) 2013-04-19 16:37:51 PDT
We have no intention of publishing further nightly builds for Snow Leopard. I'm not sure how much clearer I can state that.

WebKit nightly builds are unofficial builds of WebKit that are made available to gather feedback on new web features and to assist with early detection of any bugs introduced during development. Any use for purposes beyond that is not something we actively support. A consequence of this is that nightly builds are only expected to work with versions of Safari that were released at the time they were published.  What you're asking for is new versions of Safari to be compatible with an arbitrarily old unreleased versions of WebKit. That has nothing to do with backwards-compatibility.
Comment 8 bb553 2013-04-20 20:43:44 PDT
Respectfully, I was pointing out that OS X 10.6.8 Intel is quite in use, why it's quite in use, and that it is being updated by Apple (in terms of security updates, java updates, and Safari updates).

So, the overall situation is that:

OS X 10.4.11 PowerPC* and Intel users do have a functional version of WebKit r81558 engine to use alongside Safari 4.1.3; WebKit-533.21.1-Tiger after install, gives "Safari Version 4.1.3 (4533.19.4, 533+)" when launched and "contains all bugfixes that Apple made to the 533 series of WebKit after the release of Safari 4.1.3, which came with 533.19.4...".

OS X 10.5.8 PowerPC* and Intel users do have:

leopard-webkit - builds of current WebKit frameworks for Mac OS X 10.5 (PowerPC G4, PowerPC G5, Intel) - Google Project Hosting
[ https://code.google.com/p/leopard-webkit/ ] 

to run alongside Safari 5.0.6

OS X 10.6.8 Intel users don't have a functional WebKit engine to use alongside Safari Version 5.1.9 (6534.59.8) - unless either an individual user finds or creates a fix, or the next Safari update for OS X 10.6.8 Intel from Apple just happens to fix the issue.

Many longtime Mac users have several older PowerPC machines and a newer Intel CPU machine running side by side (all counted by Apple Corporate as "Intel" CPU users for advertising purposes), so there are clear reasons that users track software compatibility - including web browser engines - for a number of the operating systems they run on multiple hardwares. 

That's a summary of things as things stand as of April 20, 2013, and part of the point of listing the information in a clear fashion is also so that OS X 10.6.8 Intel users won't waste their time downloading WebKit r127852 for Snow Leopard at this time.

*PowerPC users also have an option instead of using Firefox 3.6.28 as an alternative for Safari/Webkit:

TenFourFox: A fork of Mozilla Firefox for the Power Macintosh 
(OS X 10.4.11 Tiger PowerPC and OS X 10.6.8 Leopard UB on PPC) 
[ http://www.floodgap.com/software/tenfourfox/ ]